We help IT Professionals succeed at work.

Shadow Copy - Cannot Find Deleted Files

I just activated Shadow copy on our main shared drive and thought it was working fine.  I placed a test file on the drive, logged into the server and ran a manual shadow copy, went back to the shared folder and deleted the test file.  Right clicked the open area, properties, Restore Previous Version.  It gives me a link to the folder, bit instead of View button I get a Open button.  When I select open, it does not show the deleted file.  It does work on modified files.

Is this a by-product of having the shadow copy on a different drive?

Comment
Watch Question

CERTIFIED EXPERT

Commented:
shadow copies keep every change. (i just checked it, wasn't sure )
when you run manually the shadow copy did it finish before you deleted the file? (you can check that form your logs)
I'm assuming that you have shadow copy activated on the drive you put the test file on and then created a restore point from that drive.

If you haven't restarted the machine yet that's what it took for me to get mine to work.

Author

Commented:
It seems that the shadow copy completes.  I hit Create and it pauses for a few moments and then shows up as a selectable option.  You can also see the size of the shadow copy change.  

Commented:
right click the folder
restore previous versions
chose you restore point  try save as

Author

Commented:
I thinkig a restart too.  Its a production server so I will have to reboot at an off hour time.  It needs to Windows update too,

I will try the reboot later this evening and post back....
Any luck with the reboot getting this fixed?

Author

Commented:
Not yet.  I was on vacation to the Caribbean.  7 day cruise.  Will test it this week.

Author

Commented:
Reboot did not fix this.....
This was a product of Windows 7 and Server 2003 not playing well together.  There was a registry fix on the 2003 Server that was needed to allow W7 to see the shadow copies properly.

http://blogs.technet.com/b/sbs/archive/2009/10/21/windows-7-cannot-access-shadow-copies-in-sbs-2003.aspx

On your SBS 2003 server, open REGEDIT and navigate to the following location:
HKLM\SYSTEM\CurrentControlSet\Services\lanmanserver\Parameters
Right click on parameters and select Export.
Once the export is completed, find the entry for DisableDownLevelTimewarp, select it and then delete it.

Author

Commented:
Just widened my search until I found this possible solution.  Even though it points to SBS 2003 it works with Server 2003 too.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.