We help IT Professionals succeed at work.

Default ID/Password for SQL 2008 R2 Express w/ SharePoint 2010 Foundation

I installed Sharepoint 2010 Foundation on a server and chose the single server, stand-alone option. This option will install SQL 2008 R2 Express and Install SharePoint 2010.

The process does not prompt for any user id or password for the database.

I need to connect to the SQL Instance using SQL Management Studio and need to enter a user id/password to connect. Everything I try does not work, so there must be a specific SQL Server Authentication based ID and password that automatically gets created.

Does anyone know what it is? I need to log into the actual SQL Express database and I can't connect to the instance because I dont have a user id or password.
Comment
Watch Question

lcohanDatabase Analyst
CERTIFIED EXPERT

Commented:
Try "Windows authentication" instead and make sure you are logged in with same user that installed the software then you could add whatever you need under security.
Commented:
Icohan, that didn't work. That's what I initially tried to do. The fix that I found is as follows.

Install SQL Server Management Studio Express the server where SQL Express is installed

Stop the SQL Server Service

Launch SQL Server configuration manager and select the SQL Server Service

Click on the Advanced Tab and go to the "Startup Parameters" section.

Change the startup parameter from:

"-d;D:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\DATA\master.mdf;-eD:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\Log\ERRORLOG;-lD:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\DATA\mastlog.ldf"

to

"-m;-d;D:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\DATA\master.mdf;-eD:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\Log\ERRORLOG;-lD:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\DATA\mastlog.ldf"

Start the SQL Server Service

Use "Windows Authentication Mode" to log into the database instance on the local server

Add the same user account that you just used to log in via single user mode, so that it is present in the SQL instance logins section and has public and sysadmin access to the instance

Stop the SQL Server Service

Change the startup parameter from:

"-m;-d;D:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\DATA\master.mdf;-eD:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\Log\ERRORLOG;-lD:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\DATA\mastlog.ldf"
 
back to

"-d;D:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\DATA\master.mdf;-eD:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\Log\ERRORLOG;-lD:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Data\MSSQL10.SHAREPOINT\MSSQL\DATA\mastlog.ldf"

Start the SQL Server Service

Try logging back in locally using the same account via  SQL Server Management Studio Express --> this now should work outside of single user mode

Try going to a remote machine and launch sql server management studio from the remote machine and try logging using the same account via  SQL Server Management Studio Express --> this now should work outside of single user mode and from a remote machine

Author

Commented:
I was able to solve the issue using the following procedure.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.