We help IT Professionals succeed at work.

Exchange 2010 mailbox name with random characters

MisUszatek
MisUszatek asked
on
We have recently migrated to Exchange 2010. When I create a job posting email address now it has some random characters added.

This is what I type in when creating the mailbox:
job051@domain.com

This is what I get when the mailbox is created:
job05132fcc9@domain.com

Why is it doing it and how to fix it?

Comment
Watch Question

Madan SharmaConsultant

Commented:
there might be some issue with your default email address policy please check that

Author

Commented:
When I tried to change it back the error message also suggest something like that. Since we outsourced the migration I am not really sure what to look for. Can you suggest what could possibly be wrong with it?
Consultant
Commented:
did you create it in exchange 2010 or its auto update from your legacy exchange if it is from legacy exchange please resync it from old server by using the following command:-
Get-EmailAddressPolicy | where {$_.RecipientFilterType –eq “Legacy”} | Set-EmailAddressPolicy –IncludedRecipients AllRecipients

if you dont have the legacy exchange then please create a new email address policy for your domain and set it as default and remove existing one.

Author

Commented:
It only happens when I manually put numbers into the Name field. We are not doing it now so it works ok. Thanks for your time!

Explore More ContentExplore courses, solutions, and other research materials related to this topic.