We help IT Professionals succeed at work.

Microsoft SCCM installation issues

I am having trouble installing SCCM on my Virtual server box. I believe maybe on of the roles are not installed but I decided to come here to the Real Professionals to possibly help me with my problem (at least until my company stops acting broke and can send me to training...LOL) So here is my scenario:
My company has 3 major offices; each major office has smaller sub-offices it is responsible for. So my plan was to make my office the Central site and the other 2 major offices (when we get the licenses) Primary sites with the sub-offices secondary sites since the connection speed for them is higher than T1. So my office is the genie pig to set this up and see how it works. So for my setup I plan to only include only my office and the sub-offices it supports and then to add the other majors in as we get the licenses to the fold. (or if this is wrong or any better suggestions please let me know.) Our major offices are on DS2's in the cloud and of course our AD is in no-way a viable working model to use, so I am planning on IP subnets... Just a little informational for ya...(smile)
1. Ok so I have a virtual server box loaded with Server 2008 R2, it is part of the domain.
2. I have a dedicated SQL Server that I have god authority over under my domain admin account (which is in another city of one of the other major offices, but that is where all of our SQL DB's are located).
3. On the server manager here are the roles I have assigned: File Services, IIS (w/webdav), Windows Deployment svc, Windows server updates svc.
4. Features: .Net 3.5, BITs, Desktop Exp, Group Policy Mgmt, Remote Differential Compression, Remote svr admin tools, SNMP svc, Windows Internal DB, Windows Powershell (ISE), Windows Process Activation svc - Process model-.net environment, Windows server Migration tool, WINS svr, Wireless LAN svc, XPS viewer.
5. All of the Server 2008 Microsoft updates have been ran.
6. Firewall is under the GP and we are running Trend Micro as well (we do on all our servers).
So I run the Prereq-checker and I get "Either the user account running Configuration Manager Setup does not have sysadmin SQL Server role permissions on the SQL Server instance targeted for site database installation or the SQL Server instance could not be contacted to verify permissions. Setup cannot continue.” Now I have tried every type of way the Entry can be entered. Since it was on the network I used the "\\servername and \\servername\db name for the instance" where I get first a NetBios error to just "servername" and in that case I get this message but also an SDK error message as well.
I am thinking that maybe a role isn't turned on, then again I read that maybe since we are making it a big part of our network, I heard that it may have to be a domain controller and I need to add the role of "Active directory Domain services" with an "SPN". And since we plan on Native mode, what about "Active Directory Certificate Services"? What am I doing wrong? Help.... If more info is needed, just let me know...

Comment
Watch Question

Desktop Applications Specialist
CERTIFIED EXPERT
Commented:
You are having lots of issues. You need a full step by step guide.


http://www.windows-noob.com/forums/index.php?/forum/54-setup-sccm-2007/  Lots of pictures and an active forum

HTH

Explore More ContentExplore courses, solutions, and other research materials related to this topic.