We help IT Professionals succeed at work.

Citrix XenApp published program launch issue

wylde342
wylde342 asked
on
Medium Priority
914 Views
Last Modified: 2012-08-13
Setting up Citrix XenApp 6 Fundamentals on Server 2008 R2 Standard (x64)

All published programs are working, except Internet Explorer which is not opening normally.  If Internet Explorer is the very first program launched to connect a new ICA connection, it works just fine.  However, if any other program is opened first to establish the connection, any and all attempts to open IE after that fail.  On the server end, there is never any instance of iexplore.exe created when it doesn't open, so it's not like the program is crashing.  Also cannot find any logged events in System/Application/Citrix/Internet Explorer logs on the server of attempts to open IE.  Any ideas?
Comment
Watch Question

Sekar ChinnakannuStaff Engineer
CERTIFIED EXPERT

Commented:
Check your group policy and make sure there is no group policy restricted in terminal services settings to allow more than one session. Also is there any specific error you receiving?

Commented:
Have you got the same problem with all users profiles?

Author

Commented:
sekarc4u, terminal services configuration on the server in question has both ICA and TCP policies to restrict each user to a single session.  When IE does not launch, there is no error message available or any log whatsoever on the server.

ailikou, the problem is universal across all profiles, regardless of access rights (user with server and domain admin has the same problem).  Also tried deleting a profile and starting from scratch to no avail.
Commented:
Stumbled upon a fix, posting solution in hope that it helps others.

All the same conditions from my original post are still true, BUT - I found that after a URL was added to the launch command string (e.g.: "C:\program files\internet explorer\iexplore.exe" http://www.experts-exchange.com) then IE would launch regardless of what point it time it was opened.  Very weird fix, but in my case, I simply had to force a specific URL to connect.

Author

Commented:
Fixed my own issue

Explore More ContentExplore courses, solutions, and other research materials related to this topic.