We help IT Professionals succeed at work.

URGENT OWA returning "cannot display webpage" after logging in

I am running MS Exchange 2003 SP2 on a Windows 2000 SP4 server. All of the sudden after years of working fine the OWA stops working today. When I try to access it I get the login prompt but after entering the correct credentials I get a "page cannot be displayed" error. This is only happening from external sites. I have accessed the OWA page from within the LAN and was able to login fine. I have checked with the company that manages the firewall and they assured me they have been no changes made there and everything looks good on that end. No changes to the server that I am aware of. I suspect maybe a Windows update screwed it up but I honestly don't know where to start.
Comment
Watch Question

CERTIFIED EXPERT

Commented:
Hi, have you restarted IIS on the server?

Author

Commented:
Oh a few other things I have done based on other recommendations found online.

Found some messages stuck in one of the outgoing queues and deleted them

Ole faithful: reboot the server

This is being logged in App log when I try to loginto OWA remotely: Event ID 101 Source: DAVEX, DAVEX is to be shutdown. Version 6.5.7654.12

After server reboots I am getting these in the system log:

Event ID:101
Source: W3SVC
The server was unable to add the virtual root '/Exadmin' for the directory "\\.\BackOfficeStorage' due to the following error: The system cannot find the path specified. The data is the error code.

Event ID:101
Source: W3SVC
The server was unable to add the virtual root '/Exadmin' for the directory "\\.\BackOfficeStorage' due to the following error: The system cannot find the path specified. The data is the error code.

Event ID:101
Source: W3SVC
The server was unable to add the virtual root '/Exchange' for the directory "\\.\BackOfficeStorage\domainname\MBX' due to the following error: The system cannot find the path specified. The data is the error code.

Event ID:101
Source: W3SVC
The server was unable to add the virtual root '/Public' for the directory "\\.\BackOfficeStorage\domainname\Public' due to the following error: The system cannot find the path specified. The data is the error code.
CERTIFIED EXPERT

Commented:
Have you checked the certificates..?

check this once.
Kamalasekar ParthasarathyMessaging Support

Commented:

Kindly please check the below link

http://support.microsoft.com/kb/259373
I am running Exchange 2003 and came across a very similar sounding problem. I noticed that the information store service wasnt started.  I started this and mounted the mailbox stores, which hadnt mounted.  We have a very large (>150GB) public folder store, i think this could be causing the issue.  

internal email access was working fine, smart phone access working fine too but outlook web access was down.  I restarted IIS and also used this article http://support.microsoft.com/kb/323664 to edit the registry to stop exchange scanning emails for viruses, temporarily, to see if this was the cause of the issue.  This allowed the information store service to start and let me mount mailboxes.

Note that a server reboot didnt seem to have the same effect as restarting IIS separately using IIS Manager.

Let me know if the above works for you.
CERTIFIED EXPERT

Commented:
I have suggested restarting IIS in case the exchangeIS had started in the wrong order or dependencies not starting etc. prior to the authors second post so have no idea if that has been done.

BIZNETplus, can you clarify you have restarted IIS after exchange is up and appears to functioning?
Well damn everything magically started working this morning. I did one last restart last night before bed, can't even remember the different things I did before that restart that may have affected it.
Our exchange server has been working on and off, one thing that works for sure is disabling the virus-scanning entry in the registry.

    In Registry Editor, locate the following subkey in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\VirusScan
    In the right pane, double-click Enabled.
    Click Decimal, type 0 in the Value data box, and then click OK.
    On the File menu, click Exit to quit Registry Editor.
    Start the Information Store.
CERTIFIED EXPERT

Commented:
Cool!

Author

Commented:
Not sure what eventually resolved the issue.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.