We help IT Professionals succeed at work.

Cannot connect to SQLServer from remote machine

SiemensSEN
SiemensSEN asked
on
Medium Priority
333 Views
Last Modified: 2012-05-12
Hello,

  I install SQLServer 2005 x64 bit on my 2008 server. However, I cannot connect to it from a remote computer using ODBC or another SSMS.  I cannot see the instance

It is name instance I called CQ2005 --

I did the following
-- enable remote connection
-- All service is running (SQL browser, database engine)
--  create firewall rule for port 1433 and 1256
-- I can connect to using ODBC and SSMS from the localhost

Comment
Watch Question

Chris MangusDatabase Administrator
CERTIFIED EXPERT

Commented:
Can you at least ping between the two machines?  If you can ping then you might need to enable TCP/IP protocol in SQL Server Configuration Manager.
Do you have Windows or SQL Authentication enabled?
Make sure you have followed all 3 of these steps.  Easier to send the kb than type it all out.

http://support.microsoft.com/kb/914277
Aaron TomoskyDirector, SD-WAN Solutions
CERTIFIED EXPERT
Commented:
In SQL configuration manager, enable tcpip, go down to the last ip all setting, remove the 0 from the upper box, put 1433 in the lower box

Author

Commented:
Thanks,

cmangus -- I can ping between machine
Getsum -- I have both SQL and Window Authentication
aarontomosky -- I have 1433  as the last ip all setting
 but still the same issue

--Mike,
  I follow the instruction in the link except for "Create exceptions in Windows Firewall" It seem to imply that this should only be done for Windows XP Service Pack 2 (SP2) and in Windows Server 2003.  

My server is 2008  do I still have to do this step

Thanks
If your win 7 firewall is on, turn it off and then try, let's see if that's causing the issue.

Author

Commented:
Also, my SQLserver is  standard edition. I intall it using a domain account that is in the server admin group.

Thanks again
Hello Mike,

 I disable the firewall on windows  and was able to connect. However, I am not sure how to fix this because I created a SQLport rule (inbound and outbound) for port 1256 and 1433

Thanks

Author

Commented:
I added a firewall rule for the SQLserver browser port (1334) and this resolve my issue

Thanks

Explore More ContentExplore courses, solutions, and other research materials related to this topic.