We help IT Professionals succeed at work.

can not establish a connection because the target machine, expressly rejected the connection SMTP EXCHANGE 2010

limmontreefree
on
Hello everybody.
I have an Exchange 2010 and a TMG server.
I'm trying to use SMTP port 587, but in the TMG when i audit the rule i have the error:
"can not establish a connection because the target machine, expressly rejected the connection"
the target machine is the Exchange server,
How can i review the SMTP configuration in the Exchange?

Thanks
Comment
Watch Question

To review the configuration, you'll want to open the Exchange Management Console and then go to Servers, click on Hub Transport, and then look at the receive connectors. The receive connectors  are where the settings live for your Exchange server to accept incoming e-mail via SMTP.
AkhaterSolutions Architect
CERTIFIED EXPERT

Commented:
before trying from the internet try from inside your network, can you telnet on port 587 to your exchange server?

Author

Commented:
thanks:

I've enabled the SMTP  port 587 in the Hub Receiver.

When i try from LAN a telnet command:
Telnet 172.16.1.20 25 or 172.16.1.20 587  a connection is established. and the console is Waiting my commands.

When i try send a test mail from Outlook 2010 the first step, Login in the incomming server pass correctle, when it try the second step, send a test mail, outllok ask me for three data:
server: mycliente.dyndns.biz
user:   myuser@domain.local
password: mi password

but don't work it asking my again.

Thanks again
AkhaterSolutions Architect
CERTIFIED EXPERT

Commented:
Can you tell me what you are trying to accomplish?

what did you enable on the HUB ? a connector on port 587 is there by default you shouldn't have anything to enable

Author

Commented:
Thank you very much for your answer.

I'd add the port for 587, in this server it was only the 25 port.

in the image is how are now.
experts01.png
AkhaterSolutions Architect
CERTIFIED EXPERT

Commented:
Ok First your should have 2 connectors and not one, so it seems someone already deleted the default connectors

OK why would you like to do it on port 587 and not 25 ?

what are you trying to do ?

Author

Commented:
Well, in spain the ISPs have the nasty habit of cutting the port 25, not really cut it but the source IP change so is not useful to send mail,  they say that it is to prevent SPAM.

They really want us to use their servers.
AkhaterSolutions Architect
CERTIFIED EXPERT

Commented:
I am sorry I didn't understand,

Author

Commented:
With our ISP we can not use the port 25 to send mail.
 The ISP say that we have to use another port.

Sorry my bad english....

and thanks
AkhaterSolutions Architect
CERTIFIED EXPERT

Commented:
No your English is much better than my Spanish I can assure you :)

I understood this far, the question is why do you want to use SMTP at all ? why not use outlook anywhere the way it should be

Author

Commented:
Ah, ok it's easy ,

My client has a program to send mails but just does POP3 and I have been asked to set some accounts to send mail with pop3.

 I also want to send other mail from programs, such as: Fax, backups, etc ...

thanks.
AkhaterSolutions Architect
CERTIFIED EXPERT

Commented:
POP3 doesn't send emails, it is just to receive emails.

SMTP is what is used to transfer emails.

when you say "With our ISP we can not use the port 25 to send mail." you mean the ISP of the client or the isp of the server?

the ISP cannot possibly block port 25 on the mailing server side if they do this exchange server will never receive any email from anywhere.


All this have nothing to do with what you are trying to do sorry I am just trying to give you a global view.

can you please share the authentication and permission group tabs on this connector ?

Author

Commented:
I have only basic authentication.

I don't know why but if a do telnet to my_client_ip_wan 25   in the TMG appear a source ip that are not mine. in can't connect, if i do the same from the client lan i connect correctly.

I do a telnet to port 587 in teh TMG appear mi Ip WAN as Source Ip and connect correctly,

I don't know how they do it, I think the ISP only permit trafic between Server in port 25.

Thanks again
Solutions Architect
CERTIFIED EXPERT
Commented:
what do you have in the permission group ?

Author

Commented:
I think you addressed this, but sometimes the words in Spanish and English are very different.

I send you two snapshot.

Thanks.

experts02.png
experts03.png

Author

Commented:
again sorry just saw this ...
experts04.png
AkhaterSolutions Architect
CERTIFIED EXPERT

Commented:
yes you see you just have anonymous userss selected, you need to select exchange users "usuarios de exchange"

hasta luego

Author

Commented:
I just mark the "Exchange Users" and i think is running,

I'll try and tell you..

Many many thanks,

latter i'll point to you and i feel bad for not being able to give more than 500 points.
AkhaterSolutions Architect
CERTIFIED EXPERT

Commented:
no te preocupes no importa el puntos

Author

Commented:
The resolution was perfect by Akhater, has followed the issue with consistency and a lot of interest.

 I want to make a mention to Akhater for his interest.
AkhaterSolutions Architect
CERTIFIED EXPERT

Commented:
Muchas gracias amigo

Explore More ContentExplore courses, solutions, and other research materials related to this topic.