We help IT Professionals succeed at work.

Terminal Services not listening on 3389

Medium Priority
1,321 Views
Last Modified: 2012-05-12
Hi all,

I have a client with a Server 2008 SP2 Standard machine. Terminal Services starts, but is not listening on 3389. The event viewer lists the following error:

Terminal Service start failed. The relevant status code was No such interface supported

I've searched through every possible solution on the internet, and no resolution. I've also tried adding the Network Service account to local admins - this did not fix it.

Please help!
Comment
Watch Question

Commented:
Hi

Was this behavior experienced from the "word get-go" or was it operational and only after some time did this happen? If it is only a recent problem, do you know if anything changed on your setup before hand? I'm concerned that you are making changes to the service account, but on the other hand I guess it depends on if this a newly installed server or just a new problem.

Commented:
Next set of questions: does this happen to all clients or only after a while of operation? Did you configure your TS server connection behavior - "end session after disconnect etc.?
If you have to many pending connections the server assumes it is under attack (more than 50 connections)
"Regfix" for this.
Change the value of the MaxOutstandingConnections registry entry to a number that is larger than 50. To do this, follow these steps:

   1. Click Start, click Run, type regedit, and then click OK.
   2. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
   3. In the details pane, double-click MaxOutstandingConnections.
   4. Enter a value that is larger than 50, and then click OK.
   5. Exit Registry Editor.
Also look at this article. (source of "Regfix" above)
http://support.microsoft.com/kb/954398

HTH

Author

Commented:
Hi Moomin83,

Thanks for getting back to me.

- I understand that it did once work, however I picked up this client from another provider so I am unsure on all of the details. Nothing has changed to my knowledge. I have another client with an identical setup that has no problems.
- This happens from system boot, it doesn't work at all for any period of time
- I have removed the terminal server role completely to eliminate it, now I've just got it setup for standard remote administration

I have tried your reg fix, unfortunately it did not fix :-(

Cheers.

Commented:
Hi

The only other solution I can think of is removing the SP and then check if it starts working again. then proceed by installing it again. (This is the only other solution to this problem I could find - and it applies to Vista :(  - might be worth trying, should be easier than reloading server)

Author

Commented:
Hi Moomin83,

I cannot find the uninstaller for SP2. I assume that it was preloaded.


Cheers.

Commented:
You can remove Windows Server 2008 SP2 from the command line by either specifying the path to the package that was used for installation (the path to the expanded .cab file), or by specifying the package identity (the package name).
Option 1: Using the package that was used for installation


Open an elevated Command Prompt window (click Start, type
command in the Start Search box, right-click Command Prompt, and then click
Run as administrator).

Run the following command, assuming that Windows6.0-KB948465-NNN.exe is in the C:\temp folder:
C:\temp\Windows6.0-KB948465-NNN.exe /x:C:\temp
Where NNN is x86, x64, or ia64.

To create a sandbox (a virtual environment), type: md <sandbox>

To remove SP2, type: start /w pkgmgr.exe /m:c:\temp\Windows6.0-KB948465-NNN.cab /up /s:<sandbox>

After Pkgmgr.exe completes, you will be prompted to restart the computer (unless you specified the
/quiet option).

Option 2: Using the package identity


Open an elevated Command Prompt window (click Start, type
command in the Start Search box, right-click Command Prompt, and then click
Run as administrator).

Run either of the following commands:

Using the 5 language package: start /w pkgmgr /up /p:"VistaSP2-KB948465~31bf3856ad364e35~NNN~~6.0.0.QQQQQ"

Using the package that contains all languages: start /w pkgmgr /up /p:"VistaSP2-KB948465~31bf3856ad364e35~NNN~~6.0.1.QQQQQ"


Where NNN is x86, x64, or ia64 and
QQQQQ is the build number..

After Pkgmgr.exe completes, you will be prompted to restart the computer (unless you specified the
/quiet option).

Source:http://www.networksteve.com/forum/topic.php/Unable_to_uninstall_Windows_Server_2008_SP2/?TopicId=22939&Posts=3

Author

Commented:
Moomin83,

I have already come across that explanation. It requires the original package.

I do not know which package SP2 was installed with (or whether it was streamlined into the clean installation), as I did not build the server.


Cheers.
Im confused.. you state that it is started and listening but then in the next sentence say the service failed to start.  So is the service even running?
Andrew OakeleyConsultant

Commented:
you say
> I have removed the terminal server role completely to eliminate it, now I've just got it setup for standard remote administration

Please confirm that; you have removed the terminal services role and now you can RDP into the server? or do you mean that you have removed the terminal services role, but it still does not work?

this might sound odd - but by any chance is this an IBM server with the IBM RAID monitoring software installed?

if you execute the following and then search netstat.txt for 3389 is anything listiening on port 3389
#> netstat -anb > netstat.txt

If you change the terminal server listing port as per http://support.microsoft.com/kb/187623 does the service start

Have you reied deleting and re-creating the RDP listener
Go to the Remote Desktop Configuration, delete tcp-rdp listener and then restart server. After booting go back into Remote Desktop Configuration and create a new rdp listener, restart server once again.

andy
Rich RumbleSecurity Samurai
CERTIFIED EXPERT
Top Expert 2006

Commented:
I've seen others mention that it should be unjoined from the domain, rebooted, see if it's working, rejoin domain, reboot, see if it works still. This link gives you 4 options to try to resolve:
http://www.digitalsupporttech.com/mskb/946/946399_The_Terminal_Services_service_may_be_unable_to_start_on_a_server_that_is_running_Windows_Server_2008.htm
-rich
Most Valuable Expert 2014

Commented:
Also is the windows firewall up? Or other firewall?

Has an exception been made for 3389 and 3390?

Author

Commented:
DMTechGrooup:

- The service is started but it is NOT listening. I never said it was listening.
- After it starts, it leaves a message in the event log, but does not stop the service.
- At no point does it commence listening on 3389.

aoakeley:

- I have removed the terminal services role, but I still cannot RDP into the server.
- This is not an IBM server, it's a HP ML330
- There is nothing listening on 3389. I have also tried changing the port that it listens on, it still does not work.
- I have tried deleting and readding the RDP listener multiple times, and assigning to different adapters, does not work.

richrumble:

I will give this a shot, thanks.

jimpen:

- The Windows firewall is installed and running, with exceptions.
- I have tried disabling it, it makes no difference
- There is no other firewall/antivirus software installed
Andrew OakeleyConsultant

Commented:
Ok clutching at straws now.....
Set device manager to show non present devices (set devmgr_show_nonpresent_devices=1)
http://www.tech-recipes.com/rx/504/how-to-uninstall-hidden-devices-drivers-and-services/ 

Confirm there are no old network adapters installed on the system, If so - remove them, and reboot the server.

Author

Commented:
Hi aoakeley,

- I've removed all old network drivers (there were a couple), however no luck.
- I've also removed from the domain, problem still persists when it's on a workgroup.

Thanks for your efforts, though.
Consultant
Commented:
Sorry out if ideas... Repair install of server? Reinstall server?
I fixed this problem by upgrading the machine from 2008 to 2008 R2.

Author

Commented:
Only option was to upgrade server.