We help IT Professionals succeed at work.

All of my income email goes directly to the deleted folder.

My email is on Exchange 2007 and my client software is Outlook 2010.  All of a sudden, all of my incoming email (both internally and externally) are automatically being routed to my deleted folder instead of my Inbox.  I checked my rules and I noticed that there was one in there that had "all messages to root goes to deleted".  I never created this rule so I deleted it, however, this did not solve the issue.  This occurs in OWA as well and also via active synch (on my phone & iPad).  I created a rule to send all message to me to the Inbox, but that didn't work either.  Its seems like the rule is being overlooked.  This is weird as I did nothing to my account to render this behavior.  I am the Systems Administrator\Exchange Administrator and I am stumped.  Any ideas?  
Comment
Watch Question

Gary ColtharpSr. Systems Engineer

Commented:
Sounds like a feature! :)

Make sure your outlook is "online" when you remove this rule that got entered in there. Otherwise exchange will still have the rule and will continue to process it.

Author

Commented:
Yes it was online when I removed the rule.  I even installed MFCMapi to look for any hidden, corrupted rules.  Found one and deleted it and still having the same issue.  This is a stumper!
Gary ColtharpSr. Systems Engineer

Commented:
Did you try deleting the profile from the local pc?

I would delete the profile, then log on to OWA and manage your rules making sure there are none in there.

Then recreate the local profile and see if it clears it up.

Author

Commented:
Yes, I've already went through suspecting it was my profile.  It seems to be a server side issue as it occurs in OWA & Active Synch.  Whats baffling is that I don't have any rules and went through the process of deleting any hidden or corrupt rules using WFCMapi.  I then tried to create a rule that sends all mail to me to be delivered to my Inbox and it seems the rule was totally ignored ... didn't work.  I don't want to go through the process of deleting my mailbox/AD account as it will cause me more trouble.
Commented:
I have finally found the solution to my problem! :)  Go to this link below.  

http://support.microsoft.com/kb/959960

I was working with a resource mailbox the morning this situation occurred.  As the article says, the rource's hidden rule must of synched with my profile.  I downloaded MFCMAPI from this location: http://mfcmapi.codeplex.com/.  Then did the following.  Note:  My autoprocessing setting was indeed set 2  <e k="18-AutomateProcessing" v="9-2"/>    I changed it to "9-0" and this fixed the issue.  

•Start MFCMAPI
•On the Session menu click Logon and Display Store Table.
•Select the profile that you just created and then click OK.
•Double-click the entry for Mailbox - User1.
•Expand the tree until you see the Calendar folder for the mailbox.
•Right-click the Calendar folder and select Open Associated Contents Table.
•Locate and select the message that uses Message Class = IPM.Configuration.Calendar.
•In the bottom pane, double-click the PR_ROAMING_DICTIONARY property.
•In the Text pane of the Property Editor, look for the following entry: <e k="18-AutomateProcessing
Note You should not see this property if you are working with a new mailbox. However, if you do see this property, the value for a user's mailbox should be either 0 or 1. The following table is the profile property that stores the setting that corresponds to the AutomateProcessing parameter for the mailbox.
PR_ROAMING_DICTIONARY value                       AutomateProcessing setting
---------------------------------------------------------------------------------
<e k="18-AutomateProcessing" v="9-0"/>           none
<e k="18-AutomateProcessing" v="9-1"/>           AutoUpdat
<e k="18-AutomateProcessing" v="9-2"/>           AutoAccept (should only be 2 for resource mailboxes)


Author

Commented:
This solved my issue of mail automatically routing to deleted.  This occured after working with a resource mailbox which inadvertently sychned its hidded rule to autoprocess to my profile.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.