We help IT Professionals succeed at work.
Get Started

Reassemble RAID 10 array without losing data

ghfllc
ghfllc asked
on
350 Views
Last Modified: 2012-05-12
I have a RAID 10 array created from 4 iSCSI devices.  This morning I temporarily lost connectivity to 2 of those drives.  And it was long enough for mdadm to take them out of the array.  Unfortunately it was the 3rd and 4th drive which left me with an unusable array.  It was automatically made inactive.  I know the data on those iSCSI drives is in tact but I can't figure out how to bring them back to an active status.  I have already tried rebooting the server but it just brings up the array in inactive mode with 2 spares.  I found a suggestion online to --create the array again with the --assume-clean option so my data won't be lost.  When I do that it says that all 4 drives appear "to be part of a raid array" but on 3 of them it also says the "partition table exists" and "will be lost or meaningless after creating the array".  If I allow it to continue will the lost partition tables mean lost data or will it be able to salvage the data?
Comment
Watch Question
Commented:
This problem has been solved!
Unlock 1 Answer and 1 Comment.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE