We help IT Professionals succeed at work.

server 500 error when uploading to server

Hi all,

I have run my site locally just fine. However when I uploded to the server (web server 2008 running IIS7) i received thef ollowing error.

Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Type System.Drawing.Point, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a in the data at line 120, position 4 cannot be located. Line 122, position 5.

So after googling it appeared that the application pool the site is set with was not configure to use asp.net 4.0. So I rightclickc -> advanced settings and changed the application pool here to be ASP.NET 4.0 (I have tried all the variations) and this is now givinga server 500 error.

Any ideas on howto fix this?

Matt.
Comment
Watch Question

Commented:
Hi flynny

Have you tried changing the app pool from the default "integrated pipeline" mode to Classic mode?

Commented:
Also worth looking into - if you open the app pool in advanced mode, you can set it to enable 32bit applications (might also do the trick). If you use integrated authentication you can also set the app pool to load the user profile, although I believe that would have given you a 400 error

Commented:
Hi flynny,

Have you been able to resolve the problem you experienced?

Author

Commented:
Hi Moomin,

Sorry for the delay. No I havent managed to solve it yet.

Now I have tried right clicking on th ewe site gone to web site -> advanced settings

Selected the classic ASP.NET 4.0 (Classic) as th app pool from the dropdown. This stills gives the 500 internal server error.

Could you provide direcions on how to change the site to accept 32 bit applications??

Author

Commented:
sorry,

Just worked out how to edit the application pools.

Ok I have edited the actual app pool to have asp.net 4.0, classic and enabled 32 bt applications. However I am still getting the server 500 error?

anything else I can try?>

Commented:
Hi flynny,

Just a thought. I assume you have applications installed on your workstation like Ajax extension or exentrics etc. Please confirm that these are also installed on the server. If this is missing that might cause the problem. (you might need to look for 64bit versions if your Server operates in 64bit) After applying the software, change all the app pool settings back to how it is set on your PC. (might need to leave the "enable 32bit" setting on if your server is 64bit)

HTH

Author

Commented:
Hi Moomin83

the server is running Web Server 2008.

How would I check this please?

Author

Commented:
oh sorry it is the 64bit version also.

Matt.

Commented:
On your Notebook compare the installed programs (XP is located in "add and remove programs" within "controll panel" and in Windows 7 it is under "programs and features" also within "controll panel") then check the server's applications under "controll panel" - "programs and features". If you have any applications like AJAX exstensions on your local PC ensure to install it on the server.(Granted you might need to find 64bit versions depending on the Server OS version)

HTH

Commented:
Hi Mat,

Then there is a good possibility you might need to find a 64bit version. the applications I'm referring to has to do with added features when developing a website. What application do you use to develop the Website?

Author

Commented:
Hi Moomin83,

Many thanks for the reply,

I am developing the site on Windows 7 64bit. Now the server is 64 bit.

I have looked at the control panel on the server and there is nothing listed here for ajax extensions.

Commented:
And on the Win 7 pc? Maybe ad screenshots of installed applications on both Win7 and server for me to view.

Author

Commented:
Ok will grab these fo ryou.

I the mean time I found this whilst googling around

http://stackoverflow.com/questions/929131/how-do-i-resolve-http-error-500-19-internal-server-error-on-iis7-0

any ideas on how I can check the permissions for the application pool user?

Commented:
My setting looks like this

App pool is set to Network service
 App Pool
Then Check the web site setting (basic settings found on right hand side of IIS Manager screen when website is selected. (Actions pane)
 PathCheck the connect settings and test it.

You can also set the Security via the directory security
 Security
HTH

Author

Commented:
Moomin83,

Thanks for this it as extremely helpful.

Looks like it could be this issue. As you mentioned I have set the application pools identity to be NetrworkService.

If I then select the basic web site settings and test the connection I get the following warning;

The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again.

just to note I have ensured that 'everyone' is added to the security and has full access.

Does this help?

Yet still I am getting the Server 500 error.

Thanks again for the great help.

Commented:
You might need to add the AD group "domain computers" to the server's Local user group. While you do that also ad the "domain users" group to that group. Then make sure that the Local users group have access to the path (wwwroot folder) and also to the website > Right click on website and select edit permissions.

Just a note on my screen capture indicating the everyone group > the everyone group was there by default but does not have any security configured. I just tried to hide personal info by scrolling to the top.

Author

Commented:
Moomin83,

Thanks again for the reply. Do I add this through the GPO? Also please see the screen grabs I promised earlier below.

Programs an Features on the Server
The programs and features on the server

Website Basic Settingsthe basic website settings

 Testing the site connectionResult of testing the site connection.

Commented:
Hi flynny,

Don't worry about the warning (test connection) to much, all my sites do the same - haven't bothered to figure it out as yet as it is not hampering any operation.

I'm going to attach a Doc as it is easier to manipulate.

IIS.docx

Commented:
Your Server control panel seems to have all the required software installed.
If the last step just provided does not do the trick - Deleted the website from the server and republish it. get the error it gives then and escalate this call to a moderator.
Reason for republish is to prevent any errors causes by my suggestions - if any, but never the less - a clean start some times works.

Best of luck - let me know.

Author

Commented:
moomin83,

thanks fo rthe great documentation.

The  domain user and domain computer groups are not in the list on the server? is there any reason for this? Is it possible for me  to create them?

Author

Commented:
Hi,

A few additonal questions and info.

1. After mimicing your screen for the athentication section i trid to enable 'ASP.NET Impersonation', this gave me error messages, saying that there were multiple references in the asp.net web.config.
I reoved these references and I now get a 404 error when trying to browse the site (does this help?).

2. I dont have failed request tracing available on the right hand pane. How do I enable this please?

3. For some reason it will not allow me to edit the permissions for the .net folders (as per last instruction on your email)? I am logged in as administrator??

Author

Commented:
Hi Moomin83,

Sorry bout the multiple posts.

giving a little more information on 1. I have tried removing the site and starting a fresh, however, I am getting the same error messages. When I go to authentication I am getting the erro rmessage;

---------------------------
Authentication
---------------------------
There was an error while performing this operation.

Details:

Filename: \\?\C:\inetpub\wwwroot\<site>\web.config

Line number: 14

Error: There is a duplicate 'system.web.extensions/scripting/scriptResourceHandler' section defined


regarding 2. above I have managed to add the failed request tracking, however, the error is not generating any log file?

3. I have managed to add the permissions to the users group to asp.net v4. folder but unfortunately it still will not allow me to edit the permissions for v2??

Hope this additional information helps.

Matt.

Commented:
Will reply shortly, busy driving
Commented:
Hi Matt

Don't worry to much about the .Net 2 permissions as you are using .Net4.
I would like a screen capture of the error on the server it self. browsing on the server gives you a more detailed error. (when opening you website on the server it might give you an error about security-just open IE > navigate to tools and select "Internet Options" > navigate to security > "Local intranet" and click on sites > and add the "binding" to this list - http://"yoursitename" for example "http://intranet".
Close IE and browse it again. If your site does not allow the detailed "debug" screen, set the following in your web.config file
<system.web>
            <identity impersonate="true" /> (Ignore this)
            <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
                  <assemblies>

It might indicate something like setting the "default page". I have to specify ours on various sites as we do not use the normal default sites added like "default.htm /asp / aspx. we use custom landing pages.

Long story short: I would like the error screen received when browsing the page on the server.

Regards

Robert

Sorry for the long delays in responses - Projects are taking all my time.

Author

Commented:
robert,

No need to apologise I appreciate your help.

Ok, after doing this the error message gave me much more detail and I have managed to solve the issue (many thanks for all your help).

The more detailed error messages on the server gave more info about a duplicate entry in the web.config. Once I removed this I then received the 404 message. However, this then gave me a little bit more information on why it was happening an turned out to be an old web.config I had uploaded when trying to fix the issue (oops!!).

The aspx auth was trying to redirect to an incorrect page.

Thanks again for all the help. At least now I have a good understanding of IIS 7!!

Thanks Robert.

Author

Commented:
Fantasic solution, extremely proactive and repsonsed immediately. I cannot thank him enough.

Commented:
Hi Matt

Glad it is working now! Have a good one! :)

Explore More ContentExplore courses, solutions, and other research materials related to this topic.