We help IT Professionals succeed at work.

Exchange 2010 Standard - How do I open up ports 993 and 143 on Exchange?

ggipson79
ggipson79 asked
on
Hello,

Our IT department is getting a new ticketing system in place. The company, called ConnectWise, has sent me a very brief document on what all the requirements are for their software to inter-mingle with Exchange 2010 STD x64.

The next requirement I have is this one (and mind you, this is all I know). I dont know if it is meaning on the Server 2008 R2 ENT x64 portion or if there are ports to open within Exchange?? Maybe someone can shed some light for me and help me out.

I need to know how to determine if ports 993 and 143 are open on the Exchange box.

Here is the link from their site on the requirements, if this helps you out: http://www.connectwise.com/university/forms/imap/imap.htm

It is step #6 in the above link.


Port 993 needs to be open to Inbound Exchange server for Secure transmission
Port 143 needs to be open to Inbound Exchange server for Non-secure Transmissions

If they are NOT open, how do I go about that?

Being that this is all the information they gave me, what do I do? Where do I start?

Thanks
Comment
Watch Question

Hendrik WieseInformation Security Manager

Commented:
Those are your IMAP, have a look at the following link for more details: http://social.technet.microsoft.com/Forums/en/exchange2010/thread/2cdc689d-4e3c-48dc-86d8-f693262aa012

Cheers!!! :)

Author

Commented:
Well, those commands are not working on 2008 R2. I did a little bit of digging and found that instead of netsh firewall set -->it is netsh advfirewall set
However, I am not seeing an "Optmode" like in the document. Does this part have to be done or can I skip it and go to the next step in the document?

Author

Commented:
Sorry, I mean "opmode" not "opTmode". I mistyped.
Either way when I type ? I am not seeing an 'opmode'.

Author

Commented:
Here are the commands I have available (I just copied and pasted)...

netsh advfirewall>set

The following commands are available:

Commands inherited from the netsh context:
set file       - Copy the console output to a file.
set machine    - Sets the current machine on which to operate.
set mode       - Sets the current mode to online or offline. Is this the same thing as "opmode"??

Commands in this context:
set allprofiles - Sets properties in all profiles.
set currentprofile - Sets properties in the active profile.
set domainprofile - Sets properties in the domain profile.
set global     - Sets the global properties.
set privateprofile - Sets properties in the private profile.
set publicprofile - Sets properties in the public profile.
set store      - Sets the policy store for the current interactive session.
netsh advfirewall>
Hendrik WieseInformation Security Manager

Commented:
As long as you enable IMAP on exchange then the ports will be open.

Author

Commented:
Ok, let me see if I can find where that setting is. I know I turned the IMAP service to Automatic. Are you saying there is a setting within Exchange itself that needs to be turned on?

*Also, we typically disable our Windows Firewall on the server. If I do this will it open up those ports?
Hendrik WieseInformation Security Manager

Commented:
Not familiar with advfirewall but I would presume that set mode is the same as opmode.

With regards to no. 6: Yes you can ignore if you enabled IMAP on exchange. I am not currently connected to my exchange server (because it is already just after 21h00 here so I am at home) but if I remember correctly you enable IMAP at Server Configuration > IMAP/POP tab. And then right clicking on IMAP and clicking Enable (Like I said this may be incorrect, but it is worth a try) :)

Hope this helps!!!
Hendrik WieseInformation Security Manager

Commented:
Sorry after Server Config you first need to select CAS then the rest (I think)

Author

Commented:
You were VERY close. It was Server configuration > Client Access > IMAP/POP tab
Both of those ports were already listed in there under IPv6 and IPv4

I went to mxtoolbox.com and did the tcp:My IP Addy:993 and it did not return anything. Windows firewall issue?? Or possibly something still not set right?

Where are you that it would be that late at night?
Hendrik WieseInformation Security Manager

Commented:
First test IMAP by using the Test-ImapConnectivity to determine if everything is working, and based on the results we can carry on, for more info refer to http://technet.microsoft.com/en-us/library/bb738126.aspx

I am in South Africa, you should be able to see what the time is here by me at the top right of my comments. I think the last comment I posted to you last night on your previous question was around 23h00.

But anyway let's get back to the task at hand. :)

Author

Commented:
The Result=Failure but it did not return an error code (see screenshot which also has the command I ran):


IMAP-error.png
Hendrik WieseInformation Security Manager

Commented:
Just a quick question: have you enabled IMAP on your exchange account?

Author

Commented:
Yes, I am looking at that as we speak. IMAP4, MAPI and POP3 are all enabled
Information Security Manager
Commented:
Download the pdf article from the following site and use it as a guide to setup IMAP: http://support.itsolutionsnow.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=138

Hope this helps!!!

Author

Commented:
Ok I belive we are good! I want to thank you for your diligence in this. get some rest and if you see anymore questions from me then feel free to chime in.

Thanks for your help!!
Hendrik WieseInformation Security Manager

Commented:
No problem at all.

Glad I could help.

Cheers!!!