We help IT Professionals succeed at work.

Windows Vista and Windows 7 display the date all in lower case, how to change it to sentence case?

I am trying to set the regional settings of a computer so it displays:

03 Thu, March 2011 instead of 03 thu, march 2011

the longdateformat dddd, dd' de 'MMMM' de 'yyyy
shortdateformat dd/MM/aaaa

in windows XP the date is displayed with the correct char case, but the same configuration in windows vista or windows 7 displays lowercase

please help, I have wasted many hours trying to find out how to do this and I guess should be easy, but I dont know how to do it...

Thanks,

Cesar
Comment
Watch Question

Commented:
For Windows 7

Start -> Control Panel -> Region and Language -> Formats / Additional settings -> Date

and fill into "Long date" folloing: dd ddd, MMMM yyyy and then apply, i tested it right now and it works.

Author

Commented:
I have done this and the result is the same, I did it again and same result
BRONZE EXPERT
Top Expert 2013

Commented:
cesar77--Did you click Apply after making the changes?
And did you see that if you click "Additional Settings", on practically any tab there is a Reset button to go back to Default?

Author

Commented:
mmm, yes I applied the changes, yep I have pressed reset button and customized again and same result, the only thing I need is to capitalize the first letter on the month...

Author

Commented:
Here is an image of my regional settings configuration and how it looks on the taskbar clock,

I have a software written in Delphi 7, and when I call FormatDateTime function with ddd mmmm format it retrieves lower case letters, and my end users want every word in Sentence Case...  Regional settings  windows clock
Any help would be greatly appreciated!

BRONZE EXPERT
Top Expert 2013

Commented:
cesar77--My little understanding of Spanish suggests that the first letter of days of the week is not capitalized.  Neither is the first letter of the months.
Of course that is different from English.
BRONZE EXPERT
Top Expert 2013

Commented:
cesar77--I should have added that maybe Windows is only trying spell things correctly for Spanish.

Author

Commented:
That  is correct, all I need is to capitalize the first letter of each word, dont pay much attention to the spanish or english, actually all the spanish formats have all the letters on lower case, unlike the english formats that capitalize correct, but I have another computer with windows xp spanish, and this one capitalizes correctly....
BRONZE EXPERT
Top Expert 2013

Commented:
I do not know where this goes in the Registry
http://www.dostips.com/DtTipsStringOperations.php

And ddd may give you a day of the week with all lower case.

Author

Commented:
jcimarron, I dont quite actually understood what you meant on your post, this page has a lot of date and string functions but is not what I need

I need to know if windows Vista can be modified so that the Dates shown in Spanish (Mexico) regional configuration, start with a Capital letter...

Thanks,

Cesar
BRONZE EXPERT
Top Expert 2013

Commented:
cesar77--From the DOS string reference I posted
:toUpper   converts lowercase character to uppercase

Are you saying that Mexico regional practice is to capitalize the first letter of the names of days of the week (and names of months)?

Author

Commented:
I dont know if the regional practice is, but windows XP does this, and Vista and 7 dont :S

BRONZE EXPERT
Top Expert 2013

Commented:
cesar77--I have not opened each of these threads, but maybe an answer is here.
http://www.eggheadcafe.com/searchform.aspx?search=Capitalizing+Format+Uppercase+Proper+Letter+Weekday+Capitalized

Author

Commented:
Hi, I was on my honeymoon, sorry for not posting on this question, I would like to leave this question open, is this possible or should I close this and create a new one?

jcimarron, what I am looking for is probably a fix from microsoft that would allow me to modify the capitalizing of words in the date format...

Thanks

Cesar
BRONZE EXPERT
Top Expert 2013

Commented:
cesar77--Don't forget that in Spanish lower case is the correct char case.  It would seem Microsoft is only recognizing that.

Congratulations on your marriage!!

Author

Commented:
Thanks!! je, I know, its the correct way, but in the program I have I generate report builder reports, and my user are Doctors, so... they want the first letter of the month to be capital... thats the reason of all this problem
BRONZE EXPERT
Top Expert 2013
Commented:
cesar77--Maybe it cannot be done.  Do the Doctors get what they want from others?  If so, ask the others.

Author

Commented:
jajaja, they feel they can get whatever they want, I will have to prove them that the correct case is lower case with documents, and let them know they are wrong :) I will enjoy this ! jajajaja,

In the meantime I will give you the points for the effort, but if someday you run into a workaround for this please let me know

Regards,

Cesar

Author

Commented:
The solution was found, not what I wanted, but for now there is nothing to be done
BRONZE EXPERT
Top Expert 2013

Commented:
cesar77--"The solution was found"  Please tell us.  
And I have no objection to your cancelling the "Accepted Solution".  You may be able to do that by clicking the red "Request Attention" button at the bottom right of your original post.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.