We help IT Professionals succeed at work.

Terminal Services Configuration

dgreer1201
dgreer1201 asked
on
I'm fairly new to Terminal Services..........so I may be missing something obvious here.
We are implementing a new ERP system for our company.  Most of the clients will be using a regular desktop shortcut to the system from their PC.
However..........we will have a few users who will be working from home/traveling salesmen that will occasionally need access into the ERP system.
I have setup a SSL VPN connection for all of those users, and that is working fine.  I have also installed Terminal Services on our Windows Server 2003 box.  I have configured the settings on it for a license server, and also purchased/installed CAL's.

In addition, I have gone in to several of the users AD profile, under Environment, and configured it to start the ERP application upon login.  This seems to be working great...........as I can log into the server as their username........and it correctly opens up the ERP application.

However.............what I am confused about is..........that is the ONLY thing it opens.  They do not even have a Start menu, task bar, etc.  There is absolutely nothing there..........only the ERP application.  Maybe this is by design, I don't know.  But it seems a little confusing not even having a start menu or taskbar..........even for me.  I know that it will definately confuse the end users.

Is there a way to change this?  I know that I have read different places on the internet that a user needs to properly log off..........and not just disconnect the RDP session..........else that session will still continue to run on the system, tying up resources.  But at this point, that is the only way to close the RDP session.
Anything else I really need to be looking at configuring/changing, since I just got this installed and setup?
Thanks for any assistance you can provide!
Comment
Watch Question

Commented:
Yes, it is by design.
Add the ERP shortcut to "...\All Users\...\Startup folder. This will solve your problem.

Author

Commented:
I'm not sure I'm following you.
This is not an actual shortcut on the desktop that they click and then it opens the program.
There is nothing at all on the desktop.
This was configured in Active Directory, under user - enviroment.
Starting Program
Start the following program at logon:
Then I give the absolute path to the executable.
Commented:
An easy way to resolve this:
    Configure the Terminal service to End a Disconnected session : xx minutes.

The setting is found :
    User Properties --> Sessions Tab.

Author

Commented:
Hey thanks for that jrwarren.
I hadn't seen that setting before, and it will come in useful.

Is there still no way to show the start menu or taskbar?

Commented:
That would depend on the ERP software.
    Does it show up in a non-windowed full screen mode for all users or just the RDP connections?
If for all users, I would suggest contacting the v endor and finding the flag to attach to the execute command that would bring it into a windowed mode.
Commented:
I response to you:

I know. I'v done it thousends of times.

Remove it from your A.D environment setting, and copy the link into the "...\All Users\...\Startup folder" of your T.S.

When I user will log in the T.S, your ERP program will start, and he/she will also see the desktop tiems, start menu...

Dont Forget to add a GPO to "not show" the shutdown button". Or else, you will find yourself having a user shutting down your TS be mistake.

This is not an actual shortcut on the desktop that they click and then it opens the program.
There is nothing at all on the desktop.
This was configured in Active Directory, under user - enviroment.
Starting Program
Start the following program at logon:
Then I give the absolute path to the executable.

Author

Commented:
I have attached a screenshot of the terminal services connection for our users.
Once the RDP connection is established, and they log in, this is what they are presented with.  It's not a full screen............but it appears to be in a windowed mode. Terminal Services Screenshot

Commented:
Oups, I pasted your response in my post by mistake. Sorry for the confusion!

Commented:
I did not need to see your screen shot.

And what if you try what I am suggesting to you?

Maybe you need more instructions on how to do it?

Let me know.

Author

Commented:
I was not providing the screenshot for you
I was giving it in reference for jrwarren's post above.

No..........I know how to configure the AD part, and setup a shortcut in All Users folder.
However...........I do not need this coming up for the Administrators account, so I'm not going to place it in All Users.  I will just place in each users Startup folder.

I have now removed the entry from AD..........and setup this same shortcut in this users Startup folder.  
However........it's still giving me the same results.

Author

Commented:
Nevermind...........it's working now.
I think it took a few minutes for the changes to AD to take effect.

Commented:
@dgreer1201:

Glad you figured it out.

Like I told you, this feature is realy by design. It can also be setup in the RDP object on the client's side, in the Programms TAB.

Glad I could help.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.