We help IT Professionals succeed at work.
Get Started

VRF Aware IPSEC Tunnel settings with scripting options.

735 Views
Last Modified: 2012-05-12
I have an edge Router that I am trying to get up and running as VRF based IPSEC concentrator. Its currently running Version 12.2(18)SXF17b Adv Ent

Ideally I would like to use Global Loopback IPs to terminate the Peering and layer 3 Port-channel .1q Sub Interfaces.

 
Specifically I have a 6509-E with RSP720-3BXL's with 2 WS-IPSEC-2G Cards in the chassis.

crypto engine mode vrf is already enabled on the chassis.

 

Wondering if i am missing anything else.

 

ip VRF TEST1

!

Crytpo keyring TEST1 VRF TEST1

Pre-shared-key address x.x.x.32 key 12345678

!

Crytpo isakmp policy 2000

encr 3DES

authentication pre-share

group2

!

Crypto isakmp profile TEST1

VRF TEST1

keyring TEST1

Match identity address x.x.x.188 TEST1

!

Crypto ipsec transform-set TEST1 esp-3des esp-sha-hmac

!

crypto map TEST1 isakmp-profile TEST1

crypto map TEST1 2000 ipsec-isakmp

set peer x.x.x.188

set transform-set TEST1

set isakmp-profile TEST1

match address 2000

!

interface Port-channel1.2000

encapsulation dot1Q 2000

ip vrf forwarding TEST1

ip address 10.98.0.254 255.255.255.0

end

!

interface Loopback2000

ip address x.x.x.32 255.255.255.255

end

!

 

Access-list 2000 permit ip 10.98.0.0 0.0.0.255 192.168.83.0 0.0.0.255 log

Access-list 2000 permit ip 10.98.0.0 0.0.0.255 192.168.82.0 0.0.0.255 log

access-list 2000 remark "ACCESS LIST USED FOR TEST1 CRYPTOMAP/IPSEC TUNNEL"
Comment
Watch Question
Network Architect
CERTIFIED EXPERT
Commented:
This problem has been solved!
Unlock 1 Answer and 1 Comment.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE