We help IT Professionals succeed at work.

Web directory browsing on IIS 7.5 problems with remote paths

ecemibm
ecemibm asked
on
Hi,

I'm trying to configure one virtual directory in my IIS 7.5 web server as I have been doing with an old IIS 6 and I'm having problems to get it. I have configured one test using a local folder as a physical path, but I need to use a shared folder in a remote computer.

The configuration is easy.
Basic Settings:
- Physical path : \\server\sharefolder
(I use a domain user in connect as with permissions on the shared folder)

Authentication:
- Anonymous Authentication enable (I use also the same user used for the basic settings section)

Directory Browsing:
- set to enable

With this configuration, the system creates a web.config file (I don't modify it)
<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <directoryBrowse enabled="true" />
    </system.webServer>
</configuration>

When I try to browse the web, I get this message:
-------------------------
Server Error in '/' Application.

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: An error occurred loading a configuration file: Failed to start monitoring changes to '\\hotsname\webtest' because access is denied.

Source Error:


[No relevant source lines]
 

Source File: \\hotsname\webtest\web.config    Line: 0
---------------------------

I don't know what I'm doing wrong... I have similiar configurations in a web server with IIS 6 working without problems.

Thanks in advanced.
Regards.
Comment
Watch Question

Commented:
This happens because you've not configured  virtual directory as an application in your IIS. To do this, run your IIS Manager (Start / Settings / Control Panel / Administrative Tools / Internet Information Services) and open virtual directory properties, then click Create button in Application Settings section of Virtual Directory tab:

Author

Commented:
It works perfectly, but in my particular case to complete the configuration it's necessary to do the following:

- add the user account with permissions on the shared folder to the local group in the web server called IIS_URSRS