Link to home
Create AccountLog in
Avatar of conorbrophy
conorbrophy

asked on

SQL Server 2008 SP2 failing becasue of issue "Setup account privileges" which says that I do not have the necessary Windows permissions.

When I try and install SP2 it never gets past the initial checks as the "Setup account privileges" check fails. Its says that

"The account that is running SQL Server Setup does not have one or both of the following rights: the right to back up files and directories, and the right to manage auditing and the security log."

I am logged on as a local administrator and therefore I cannot understand why I do not have the necessary permissions.

Regards,

  Conor
Avatar of khairil
khairil
Flag of Malaysia image

Hi,

Try this, right click on the setup.exe in SP2 and ran it as an administrator.
Avatar of conorbrophy
conorbrophy

ASKER

No I have tried that and it still fails. Thanks for the suggestion.
Avatar of jerseysam
Have you run the prerequisite checker? Is this where you find the issue?

Guide to install:

http://msdn.microsoft.com/en-us/library/ms143219.aspx

Also see article regarding required rights:

http://support.microsoft.com/kb/2000257


The issue arises when I run the SP2 executable. It is the first screen that comes up, the "welcome" screen, where it checks all the prerequisites.
ASKER CERTIFIED SOLUTION
Avatar of jerseysam
jerseysam
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Yes I am logging in with a domain user which I have put in as a local administrator.
Even when I log in as a domain administrator I get the issue. I think its a Windows issue but it just surprising that it allows me to install the base software but not the SP on top of it.
Yes that is very odd. Maybe try and download the Service Pack again in case something is wrong with that install? Corrupted or soemthing?

Otherwise run Windows updates and reboot server then log back in as Admin and try again.
Why not log as local administrator instead of domain user?
I tried that. I created a local admin and it still threw up the same error.
OK I think the problem was due to logging in under the actual domain that the server is on. If you log on under a non-domain user with local admin privs or under a domain user which has a trusted relationship with the domain it does not seem to be enough.
.