We help IT Professionals succeed at work.

SBS 2003 DHCP Not Enabled Node Type Unknown

MRG_AL
MRG_AL asked
on
We recently had to upgrade our internet modem and remove the previous ip address in order to add a string of 5 static ip addresses which originally was completed incorrectly. Now our service provider fixed the ip addresses so they do register as active although our client computers and servers are having issues connecting to our server and our server ipconfig is showing DHCP is not enabled and Node Type is Unknown.

I checked our DHCP and see our server and the scope does see some client computers and their ip addresses although it does not see any printers.

In regard to the Node setting I tried changing the registry which the Enable Proxy currently shows as 2. I changed it to 0....rebooted the server and it changed back to 2 after the reboot. The client computers show the Node should be Hybrid. If some one could help me enable the DHCP and get our server back to its orginal state I would greatly appreciate it.

Thank you
Comment
Watch Question

Gary ColtharpSr. Systems Engineer

Commented:
I'm not certain I completely understand what your service provider did here. But basically, if you check the ipconfig /all on a client computer, the DHCP server should be the IP of the SBS server. If it is not, then DHCP is enabled on the router and that will cause you all sorts of problems. The first of which would be the deauthorization of the DHCP server on the SBS.

The server's ipconfig SHOULD say that DHCP is not enabled because it uses a static IP.

Hope this helps.
BRONZE EXPERT
Top Expert 2013

Commented:
No sure I completely follow but:
>>"our server ipconfig is showing DHCP is not enabled and Node Type is Unknown"
DHCP should not be enabled on your SBS. IPconfig refers to the client service. SBS runs, or should run, the DHCP server service. If you are seeing current addresses in the address pool of the DHCP console, it is likely working.

The server must have a static IP, and it's NIC must point ONLY to itself. It should have DHCP enabled and your router needs to have the service disabled. If it is enabled on the router, SBS will turn off its own DHCP service.
If the LAN IP of the server needs to be changed you must use the change server IP wizard under server management | internet and e-mail. Only do so if you absolutely have to. SBS has been known to die upon changing the LAN IP, though primarily when not using the wizard.

Anytime you make network changes such as; LAN IP, routers, or ISP configurations you need to run the connect to the internet wizard under server management | internet and e-mail. Within the wizard only make changes to anything that changed with your ISP.

Once all is complete you can reboot the PC's to force them to get an IP and addressing information from the SBS. Doing so will insure their NIC configuration points only to the SBS for DNS and assign them the appropriate gateway address.

If you connect remotely to your server you also need to update your public DNS and MX records to reflect the new public IP's.

Author

Commented:
The client computers show that the ip address of our firewall is the DHCP server and the WINS server is the SBS. DHCP is enabled on the client computer and Node Type is Hybrid.

So if I'm understanding completely DHCP should NOT be enabled on the Server?? Which would make sense because it is enabled on our firewall. So our firewall is designating the IP addresses.

When I pull hp the DHCP on my server it always says not connected. I click on it and it turns to active and under the address leases I do see client computers. Just not the printers.

When our internet service provider downloaded the new IP addresses to our new modem they ran into all sorts of issues and it did not download correctly therefore our service wasn't running correctly and we were told it was on our side. So changes were made on our server to try and fix an issue that wasn't ours and after our service provider fixed the issue with the new ip addresses now we are trying to get the server back to its orginal state.
Gary ColtharpSr. Systems Engineer

Commented:
the NIC in the server should be static....SBS should BE your DHCP server. You need to disable DHCP in the internet gateway and re-authorize the DHCP server in SBS

Author

Commented:
This will probably sound dumb but I disabled dhcp from the internet gateway and how exactly do I re-authorize the dhcp on the sbs?
Gary ColtharpSr. Systems Engineer

Commented:
Make sure the dhcp server service is running.
Open the DHCP manager, right click the server and authorize

Reboot your workstations.

Author

Commented:
Our new modem we received from our internet provider on Monday had dhcp enabled so I called and had that disabled. Authorized the dhcp on the server, rebooted and the dhcp on the NIC still is not enabled.
BRONZE EXPERT
Top Expert 2013

Commented:
As mentioned: DHCP on the server's NIC should not be enabled.

There are two DHCP services:
The DHCP client service. => The server can be a DHCP client which gets it's IP from a DHCP server (not itself) which is what you see with an IPconfig. This should not be enabled, it is for use by the workstations. The SBS should have a static IP, and DHCP will be shown as disabled in an IPConfig.

The SBS also has a DHCP server service, which runs the DHCP console and allows the server to provide IP's to the client machines.
If there was another DHCP server on the network, SBS will shut its own server service down. You can restart this in the services management console.
BRONZE EXPERT
Top Expert 2013

Commented:
Could you post the results of IPconfig /all from the server please.

Author

Commented:
So when I open DHCP through the administrative tools it shows as Not Connected in the status. I double click it and it says active then if I close that window and reopen it it says not connected again.
Gary ColtharpSr. Systems Engineer

Commented:
Reboot the server...
BRONZE EXPERT
Top Expert 2013

Commented:
Have you run the connect to the Internet wizard yet? It will configure the server's DHCP service as well, so lng as it is not disabled.

Author

Commented:
I checked our DNS through administrative tools also and it has 2 zones in the forward lookup zones. One of which is our server and the other is almost a complete duplicate although it contains a few additional charactors in the name and ip address in the properties. Should we have two zones??? Could this be my issue??

Author

Commented:
I have run connect to the internet wizard and it goes through everything fine but I still end up at the same point
Gary ColtharpSr. Systems Engineer

Commented:
On SBS, 2 zones is expected...one is for inside replication of outside addresses, the other is for inside registrations.

Reboot the SBS.
BRONZE EXPERT
Top Expert 2013

Commented:
If DHCP keeps stopping are you sure the re is no other DHCP service enabled on a router or modem? SBS will shut down if it sees one.

Author

Commented:
I will reboot again. Our internet provider said they disabled the dhcp and our firewall also has dhcp disabled but it is set to allow our trusted network to set up dhcp and our trusted network is our server.

Thank you for the reponse about the dns
BRONZE EXPERT
Top Expert 2013

Commented:
If you reboot a PC, does it get a DHCP address? If SBS is not woking and it does, it would sound like there is another DHCP server still present.

You could also disconnect the SBS and 'repair' the DHCP service and see if it contiues to function, if so it would indicate the presence of another DHCP server.

Author

Commented:
I rebooted the server and it still shows the dhcp as not connected.

I then rebooted a client computer and in the ipconfig it shows the the ip address for the sbs as the dhcp server, dns server, and primary wins server. The ip address for the firewall is the default gateway.
BRONZE EXPERT
Top Expert 2013

Commented:
When you say not connected, I assume you mean in the DHCP console? Which of the following Icons is displayed:
http://technet.microsoft.com/en-us/library/cc784812(WS.10).aspx
Gary ColtharpSr. Systems Engineer

Commented:
It sounds like functionality has been restored...  so now we are just down to the console.

Open the DHCP console...dont double click.

Right click "DHCP" and Add server

You should see your server in the list of authorized servers. Select it and add.

Author

Commented:
When I pull up DHCP through the administrative tools it does not show either icon but in status it says Not Connected.
When I pull up the DHCP through the server management it says Not Connected in the Type column.

Both locations have the icon without anything in the lower left hand corner until I double click it and then there is a little green arrow that appears in the lower left hand corner of the icon and the status changes to active for as long as I keep the window open.

Author

Commented:
I'm sorry I didn't scroll down far enough on the attachment. When I open the dhcp through the first icon in the table appears. When I double click it the second icon appears.

Author

Commented:
Gcoltharp,
I followed those steps. Should the DHCP then show as connected when I close the window and open it back up or atleast active?
Gary ColtharpSr. Systems Engineer

Commented:
after you add it. You may have to right click and authorize it. but yes, it should.

Author

Commented:
It doesn't stay connected or active. I added the server and authorized it, rebooted and it was still not connected. I did the steps again closed the dhcp and reopened it still not connected.

Gary ColtharpSr. Systems Engineer

Commented:
Double check that the server is using its own IP as the only DNS server

Author

Commented:
What do you mean by the only DNS server?
Gary ColtharpSr. Systems Engineer

Commented:
network properties of the ethernet interface on the server...

IP,
Mask
Gateway

DNS1
DNS2

DNS 1 should be the same as IP

DNS2 should be blank

Author

Commented:
I only show one DNS and it is the server ip address as is the WINS Server
BRONZE EXPERT
Top Expert 2013

Commented:
If you open the DHCP management console and get it connected, then rather than closing and reopen, highlight the server name and click on Action/refresh on the menu bar does it disconnect. wait a few minutes and try it a few times. If it does my money is on another DHCP server still present.

Author

Commented:
We completely removed the firewall, modem, switch and rebooted the server and is still will not keep the dhcp in active/running mode. Could there be another dhcp on our server that is blocking our dhcp that we have authorized? We do not show any other dhcp's in the dhcp administration link
BRONZE EXPERT
Top Expert 2013

Commented:
I assume you left the server disconnected while testing?

The only possible conflict on the server itself would be within RRAS. If making changes to RRAS I usually recomend doing so from the console, rather than remotely just in this case you loose connectivity, though there should be no problem here. To check go to administrative tools | routing and remote access | expand server name | expand IP routing | right click on NAT/Basic firewall (if present, if not you are OK) and choose properties | Address assignment | is "automatically assign an IP by using the DHCP allocator" checked?  If so and you have a single NIC, or if multiple NICs and it is bound to the LAN adapter it could cause your problems.

Author

Commented:
The automatically assign ip addresses in the rras is not checked

Author

Commented:
I also noticed in the network connection properties in the rras under NAT/Basic Firewall the inbound filters has a source address that is the beginning numbers of our static ip range. Because we are going directly through a firewall shouldn't that source address be the beginning numbers of the ip address of our firewall??

RobWill we did leave the server disconnected while testing.
BRONZE EXPERT
Top Expert 2013

Commented:
RRAS packet filters would be unrelated to your DHCP issue. They can be very confusing and are very seldom used. I am surprised you have them enabled. Do you have ISA server installed (i.e. SBS premium)?  I did a blog article a while back about packet filters if you want to compare notes, but to be honest I would have to get my head back "in that space" to comment. There are inbound and out bound source rules and they often seem backward to what you would think. It's not likely an issue here.
http://msmvps.com/blogs/RobWill/

Author

Commented:
I did not initially set up the sbs but do not see anything regarding ISA on the server.

I did notice that our client computers show the node type as hybrid and the server shows node type as unknown. Could that be related to my issue at all??
BRONZE EXPERT
Top Expert 2013

Commented:
>>"server shows node type as unknown. Could that be related to my issue at all??"
No. Node types are related to NetBIOS traffic.
http://www.tech-faq.com/netbios-node-types.html

Author

Commented:
I'm sorry I'm pulling at strings. This makes no sense. Everything was running fine on our server until we got a new modem and now the dhcp just will not run on the server. Actually if we have client ip addresses in the dhcp address leases under scopes does that mean that it is working and just doesn't see the printers? I deleted one printer and tried to add it back on and the network no longer sees the printer.

The main issue is that now our employees can not see our internal site or any printers.
BRONZE EXPERT
Top Expert 2013

Commented:
If DHCP is stopping, it is not working.
I am running out of ideas.

Author

Commented:
In services it is not stopping. But when I open the DHCP through administrative tools it says not connected. Same is true when I locate DHCP through server management. But both DHCP Server and DHCP Client are both Started in services
BRONZE EXPERT
Top Expert 2013

Commented:
If you open the DHCP management console and right click on the server name does it show "unauthorize"? It should, which indicates it is authorized.

Author

Commented:
Yes. The DHCP is authorized and is the only authorized DHCP on the server. We have unauthorized it and reauthorized it. Added it. removed it. Added it again and authorized it. It seems like my only option left is to remove DHCP and re add it to the sbs. What are your thoughts on that?
BRONZE EXPERT
Top Expert 2013
Commented:
I don't have any better options :-)

Author

Commented:
I will try that first thing tomorrow morning. Thank you for all your help.
BRONZE EXPERT
Top Expert 2013

Commented:
You are very welcome, but I appologize we haven't come up with a solution for you.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.