virgo0880
asked on
creating lv on aix
Hi All,
I have to delete the lv and create the lv and filesystem with 512 block size in AIX 5.3. What is the command for the same. for e.g. I have 2 filesystems :
/dev/erppt_redo001lv /oracle/test/redo001
/dev/erppt_redo002lv /oracle/test/redo002
Now, I want to delete redo002 lv and re-create it with 512 bytes block size. How can I do that. Also what is the procedure of deleting the filesytem and re-creating it and how can we rename the lv in AIX.
Thanks
virgo
I have to delete the lv and create the lv and filesystem with 512 block size in AIX 5.3. What is the command for the same. for e.g. I have 2 filesystems :
/dev/erppt_redo001lv /oracle/test/redo001
/dev/erppt_redo002lv /oracle/test/redo002
Now, I want to delete redo002 lv and re-create it with 512 bytes block size. How can I do that. Also what is the procedure of deleting the filesytem and re-creating it and how can we rename the lv in AIX.
Thanks
virgo
ASKER CERTIFIED SOLUTION
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.
ASKER
Currently, my filesystems are showing as :
/dev/erppt_redo001lv /oracle/test/redo001 jfs2 Oct 10 21:24 rw,cio,log=INLINE
/dev/erppt_redo002lv /oracle/test/redo002 jfs2 Oct 10 21:24 rw,cio,log=INLINE
so if I create the filesystem, whether this options will come by default i.e. log, rw option ?
/dev/erppt_redo001lv /oracle/test/redo001 jfs2 Oct 10 21:24 rw,cio,log=INLINE
/dev/erppt_redo002lv /oracle/test/redo002 jfs2 Oct 10 21:24 rw,cio,log=INLINE
so if I create the filesystem, whether this options will come by default i.e. log, rw option ?
1)
rmfs always deletes the LV along with the FS, if it's jfs/jfs2.
A workaround is removing the filesystem's stanza from /etc/filesystems, so the system will no longer know about its existence.
This method is rather uncommon (although it works).
Why wouldn't you just run those 2 additional mklv commands?
2)
You need more crfs options, according to the info you gave:
crfs -v jfs2 -a agblksize=512 -a log=INLINE -a options=cio -d erppt_redo001lv -m /oracle/test/redo001
crfs -v jfs2 -a agblksize=512 -a log=INLINE -a options=cio -d erppt_redo002lv -m /oracle/test/redo002
rw is the default. Consider adding "-A yes/no" for automatic mount at system startup.
wmp
rmfs always deletes the LV along with the FS, if it's jfs/jfs2.
A workaround is removing the filesystem's stanza from /etc/filesystems, so the system will no longer know about its existence.
This method is rather uncommon (although it works).
Why wouldn't you just run those 2 additional mklv commands?
2)
You need more crfs options, according to the info you gave:
crfs -v jfs2 -a agblksize=512 -a log=INLINE -a options=cio -d erppt_redo001lv -m /oracle/test/redo001
crfs -v jfs2 -a agblksize=512 -a log=INLINE -a options=cio -d erppt_redo002lv -m /oracle/test/redo002
rw is the default. Consider adding "-A yes/no" for automatic mount at system startup.
wmp
ASKER
Thanks for the commands and explanation, appreciate that. I will do this and see how it goes.
virgo
virgo
ASKER
OK
ASKER
This I have to do as we are facing some oracle performance issues with redo filesystem and IBM told to change the agblksize from 4k to 512. So can I do this without recreating the LVs and just removing fs and re-creating it ?
thanks
virgo