We help IT Professionals succeed at work.

administrative share not created after adding an RDM to virtual server

Hi,
I had a LUN that was no longer needed on one of my virtual servers where it was added as a raw disk mapping. I deleted the disk and added the now available RDM to another virtual server. I mapped it as drive letter H and formatted it. Now, when I try to access the drive from any other machine the administrative share \\server_name\H$ is not available. I go the the server's file and share administration mmc and I see admin shares for all my RDMs except for the one I just added. No matter how I try to add the H$ it doesn't work.
Can somebody please let me know what am I doing wrong? I've never had this happen before. Every time I added an RDM in the past I got the admin share for that drive.
Thanks.
Comment
Watch Question

President
CERTIFIED EXPERT
Commented:
Check the registry to see if the AutoShareServer entry is missing or is set to "0" (disabled).  This setting is in the following registry location:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

If the entry is set to "0," change it to "1" and restart the server.

If the AutoShareServer registry entry does not exist, follow these steps to create it:

1. Locate and then click the subkey in the registry.
2. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
3. Type AutoShareServer, and then click OK.
4. Double-click AutoShareServer, type 1, and then click OK.
5. Restart the server.

Author

Commented:
Thanks hypercat. I added the registry key per your info. I can't restart the server since it is being heavily used now. I hope to do this over the weekend and hopefully this will fix the problem. I'm still buffled as to why it did't create the admin share without this key? None of my other servers have this key, yet it always worked.

Do I also need the AutoShareWks key?

I'll report (and accept as the solution) back after the reboot.
Thanks!
Hypercat (Deb)President
CERTIFIED EXPERT

Commented:
Not sure why this would happen, either, but let's see if the solution works. Try adding both entries, although I'm not 100% you would need to second one.  I'm not even 100% sure this will fix it, but it's worth a try.  If all of the other admin shares are there, it's very odd that this one wouldn't be created automatically.  Have you already tried creating a hidden share manually on the server by creating a manual shared resource for that drive and naming it H$?

Author

Commented:
Yes, I tried adding it manually, but got the message saying it already exists, yet it is not visible and not listed. I am a domain admin, so this is not a an issue of correct access rights. I asked another domain admin to access h$ and he got the same error saying that the drive doesn't exist. We'll see what the reboot does.
Thanks.

Author

Commented:
Thanks! Addin the registry value and rebooting fixed the problem.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.