We help IT Professionals succeed at work.

One XP workstation slow to open shared files on SBS 2003 server

mzamyl
mzamyl asked
on
I manage a small law office with one SBS 2003 server and 5 Windows XP workstations.  We have a switch and a modem from our ISP that is a Gigaset 4300.  About 2 years ago there was a server crash which somehow damaged Microsoft Exchange.  Outside tech help was unable to fix it so we now use POP3 for our emails and don't go through the server.  All was working fine until last week when I had to reformat one of the workstations and reinstall Windows XP.  I got that workstation connected back to the server, but somehow it affected one of the other workstations which is now experiencing long lag times in opening shared files.  It often gets the trying to connect to server animation.  The internet works fine.  This is the only workstation affected and the reformatted one works fine.

The connections on all are set to obtain IPs automatically and obtain DNS automatically.  When I look to see what they are actually using for DNS it is 192.168.254.254 which is the Gigaset 430.  If I change it to the server IP 192.168.254.50, the workstation can't get email.
This morning the workstation first try would not log on, then 15 seconds later on second try, logged on fine. I can ping the server by name, by isp and I can ping the modem. The server can ping the workstation by IP and by name.

I am not an IT person, but have some experience with networking because before this I ran a 2 lab network in a school.  I think some kind of conflict is happening with the workstation, but I don't know how to trace it down.  Any help is appreciated.
We also run Symantic Anti-Virus Corp. Edition, but I turned it off temp. to see if that would help.  It didn't.
Comment
Watch Question

Hypercat (Deb)President
CERTIFIED EXPERT

Commented:
When using SBS, you need to make sure that the following conditions are in place:

1.  DHCP is running on the SBS server, NOT on the router.
2.  The server and ALL workstations are set to use the SBS server for DNS, not the router.
3.  The server and all workstations are set to use the router (Gigaset 4300) as the default gateway.

It sounds like perhaps your ISP's router is running DHCP, which would cause the SBS server's DHCP service to stop. This may have been going on for a long time, and may have been working to some extent, but in fact it is not the optimal way to configure this setup.  You would need to disable DHCP on the router before you will be able to get the SBS server DHCP service to start and begin working properly.  If you have any questions on how to set the DHCP scope options properly so that the workstations will get the correct DNS and default gateway settings, post back and I'll help you out.
System Admin
CERTIFIED EXPERT
Commented:
log into Gigaset 4300 in the lan settings in DHCP scpe add your local DNS ip  192.168.254.50 aand wan192.168.254.254 ...thats it..
when the pc gets the DNS it'll get 2 dns on the pc..

becouse your router is working as well as switch...

so disable the DHCP on the small business server...

all the best

Author

Commented:
I know that this is not the optimal set-up. I am not sure I know how to change any settings in the router.  They were preset by the ISP.  
Hypercat (Deb)President
CERTIFIED EXPERT

Commented:
Well, to establish whether DHCP is actually running on the router or on the server, you can go to the Services console on the server (Start/All Programs/Administrative Tools/Services) and find "DHCP Server" on the list of services.  If it is set to Automatic but is not running, then the problem is that DHCP is running on the router. You'd probably have to call your ISP to get the user name/password for that router so that you could turn it off.  If in fact the DHCP service is running on the SBS server, then all you need to do is change the DHCP scope options so that the SBS server is the DNS server and the router is the default gateway.

Author

Commented:
OK I logged into the Gigaset 4300 and I changed this:
 DNS Server: 192.168.254.254  Primary       or Self
DNS Server:192.168.254.50  Secondary       (Optional)

Do I need to change this?

DNS Suffix:       domain.invalid
Hypercat (Deb)President
CERTIFIED EXPERT

Commented:
It actually doesn't matter what DNS server is set on the Gigaset - what you have there is fine.  What matters is that DHCP and DNS need to be running on the SBS server and the server and all workstations need to be set the way I described above. Could you determine whether DHCP was running on the Gigaset and if so, how to turn it off?

Author

Commented:
I am getting conflicting advice here.  Going to have to think through this.
Hypercat (Deb)President
CERTIFIED EXPERT

Commented:
Yes, you are getting conflicting advice from two different people.  The key information here is that you need to have only one device - either the Gigaset router or the SBS server - manage and control your DHCP settings and your DNS name resolution.  Using a router for DHCP and DNS works fine in a home situation or in a small business situation where there is no server running those services.  The right way to do this for any Windows domain, including SBS, is to have the server do both.  It is possible to have a router do these things, but it can cause problems, one of which is exactly what you are describing in your original question.
Andrew OakeleyConsultant

Commented:
SBS server should do DHCP and DNS
DNS on sbs server should forward dns requests for Internet addresses to your ISP DNA server (or router)
Workstations should only use SBS server for their DNS.

Author

Commented:
This worked for me.  I know it is not the optimal solution, but since our server was partially damaged in a crash 2 years ago and we spent a lot of money on outside help and never got it totally back to correct, I was hesitant to change a lot of things on the server when 4 other clients had no problems with their connections.  This fix solved the 1 client computer that was slow.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.