Link to home
Create AccountLog in
Avatar of LindsayCole
LindsayColeFlag for Canada

asked on

Port Forwarding - Two Routers and RDP

Hello All,

 My goal is to segregate a separate domain and domain controller from the production in house network. I need to provide the separate domain with internet access. I also need to allow for RDP on a separate port (this has been configured on server, and firewall rule changed on server).

 On the HP I have setup another VLAN (2) and tagged it as participating in VLAN 2. I have also untagged the port in VLAN 1.

 IP Ranges in house;

 Production network: 192.168.1.X
 Gateway: (Router 1) 192.168.1.254

2nd Network RV042 Router 2: 192.168.1.24 (external- gets IP from 1.x range) / 192.168.10.1 (Internal)
 Separate DC: 192.168.10.2

The separate DC is not allowed to see any other PCs or servers on the network, which is why I am using a second router. It will be used as a hosted terminal server for a different business entity.

I am trying to pass RDP through on a different port (4000). I opened the port 4000 on R1, and pointed it to R2. I then opened the port on R2 and pointed it to the DC sitting on 192.168.10.2.

For some reason, it still isn't passing through. When I use canyouseeme.org to test the port, it shows it as closed.

Thanks in advance for the help!
Avatar of Gary Coltharp
Gary Coltharp
Flag of United States of America image

Are you translating prot 4000 to port 3389 on router 2?
Avatar of LindsayCole

ASKER

No, since I did a registry change on the server to accept RDP on port 4000 instead of 3389.
ASKER CERTIFIED SOLUTION
Avatar of Gary Coltharp
Gary Coltharp
Flag of United States of America image

Link to home
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.
See answer
SOLUTION
Link to home
membership
Create a free account to see this answer
Signing up is free and takes 30 seconds. No credit card required.
Points for effort.

The problem ended up being wrong port forwarding rules on the router. I must have fat fingered typed them in.

Both of the troubleshooting steps you guys provided pointed me in the right direction.

Thanks.