We help IT Professionals succeed at work.

MTU on HP NC375T PCI Express Quad Port Gigabit Server Adapter

I am trying to set the MTU for Jumbo packets on Cent OS 6.  When ever I set it about 1500 I get "SIOCSIFMTU: Invalid argument" and "WARNING: NC375T supports only the default MTU of 1500 bytes" shows up in the messages log.  I updated the driver and firmware to the lastest and still get the messages.  Here is some ethtool output:
 
# ethtool -i eth0
driver: nx_nic
version: 4.0.556
firmware-version: 4.0.556
bus-info: 0000:01:00.0
 
I am getting ready to install Windows on it just to see if I can pass a jumbo packet with the card at all.  The docs say"
 
MTU:

Default: 1500
Range : 0-8000
See the Examples section below on how to set the MTU
 
Any Ideas?  Thanks
 
- Tim
Comment
Watch Question

Software Engineer
BRONZE EXPERT
Distinguished Expert 2019
Commented:
afaict, the standard linux driver of a recent kernel (3.0.6)  has the word jumbo all over the place.
(It's name there: netxen from QLogic.)

what does ethtool -g tell you?

Author

Commented:
It ended up being a firmware issue on the NIC.  I had to back-rev it two releases before it would allow Jumbo frames.  The version that worked is 4.0.544.  Thanks for your help.

- Tim

Explore More ContentExplore courses, solutions, and other research materials related to this topic.