We help IT Professionals succeed at work.

Cisco 3750 IP Address

itdeptneci
itdeptneci asked
on
Medium Priority
365 Views
Last Modified: 2012-05-12
Hi, I'm just setting up a Layer 3 swx for the 1st time so go easy on me if I'm asking something a bit dumb. My question is; if I have vlan 11 say with address range 172.16.1.1 255.255.255.0, how can I issue the the switch with an ip address within that range.

Regards
J
Comment
Watch Question

Commented:
Hi. You create what is called a Switch Virtual Interface (SVI) named Vlan### where ### is the VLAN number and configure it with the IP address and mask

In your case, if the address is 172.16.1.254, in configure mode:

interface Vlan11
  ip address 172.16.1.254 255.255.255.0
  exit

To remove this interface, just use the no form:
no int Vlan11
conf t

make sure the vlan is created

vlan 11

interface vlan 11
 ip address 172.16.1.x 255.255.255.0
 no shut

Commented:
The following commands below walk you through start to finish, you will hit "enter" after each command:

switch>enable
switch#configure terminal
switch(conf)#vlan 11
switch(conf-if)#name Management
switch(conf-if)#exit
switch(conf)#interface vlan 11
switch(conf-if)#ip address 172.16.1.1 255.255.255.0
switch(conf-if)# description put description here is you want
switch(conf-if)# no shutdown
switch(conf-if)#end
switch# copy run start


The above commands will create the vlan first, then allow you to go into the interface and configure an IP address, then put a description of what that vlan is for (i.e. voice, data, video, etc...). After you describe you vlan you enter the no shutdown command and that makes the Vlan active. The end command brings you back to privilege mode (#) and the last command is to copy your changes to the running-configurations to the startup-configurations so that if you power down  your device the changes won't be lost.

Now that you've created this vlan, you need to assign ports to it. The commands below show how to add a single port, or a range of ports to save time. When at the prompt, the symbols denote whether you're in "user" mode, or "privilege" mode. User mode will have a > symbol. Privilege mode will have a # symbol. Global mode will look like this (conf)# - When you are in (conf)# mode you can access other areas of the switch, such as interface mode, line mode and so on.

To add interfaces to a vlan - note the commands below will be abbreviated to show you a faster way to do this. You can see the difference from the commands above.

Adding one interface to VLAN 11:

switch>en
switch#conf t
switch(conf)#int fa0/1
switch(conf-if)#switchport mode access
switch(conf-if)#switchport access vlan 11
switch(conf-if)#no shutdown
switch(conf-if)#end
switch#copy run start

Adding all of the interfaces to VLAN 11

switch>en
switch#conf t
switch(conf)#interface range fastethernet0/1 - 48
switch(conf-if)#switchport mode access
switch(conf-if)#switchport access vlan 11
switch(conf-if)#no shutdown
switch(conf-if)#end
switch#copy run start

These are basic commands for setting up a VLAN and assigning ports to that VLAN. Note, if you had a gigabit  switch, the "interface fastethernet" command would be replaced with "interface gigabitethernet."

Explore More ContentExplore courses, solutions, and other research materials related to this topic.