We help IT Professionals succeed at work.

SQL Exrpess 2008

Hi,

I have installed sql express 2008 but now would like to connect to it. Whatever I try, I cannot connect to the local instance (localhost), services are started.

Please advice.
J.
Comment
Watch Question

CERTIFIED EXPERT

Commented:
How are you trying? What do you already have..
Senior .Net Consultant
CERTIFIED EXPERT
Top Expert 2016
Commented:
have you tried (localhost)\SQLExpress

Author

Commented:
I get the message in att. whatever account  I use.
The strange thing is that I'm logged on as administrator but files I save are under the admin-user (a user I used before). I don't see an administrator-profile ... bizar.
2011-11-05-217.jpg

Commented:
Check whether the service is running or not.
Try connnecting to (only dot) if the service is running.

Author

Commented:
Services are running as mentioned in first post.

Author

Commented:
I just install sqlexpress (next, next finish) and try to connect via management studio?
Or are there other steps to take?

Commented:
From http://www.connectionstrings.com/sql-server-2008

Server=myServerName\theInstanceName;Database=myDataBase;Trusted_Connection=True;

Use your servername instead of loclhost. Plus, i assume you are connecting with Windows authentication and your login has permission to connect to it.

From the management studio it would be the same thing, put the servername\sqlexpress as the database server and select windows authentication.
Aaron ShiloChief Database Architect
CERTIFIED EXPERT

Commented:
hi

when you install under the security settings did you add the currsent user
so you will be able to connect later ?

did you supply a password for the SA user ?

if answered YES then check under the Sql Server Configuration Manager and look under protocols to see if the TCP/IP protocol is enabled.

Author

Commented:
I had to fill in servername\sqlexpress, that did the trick!

Explore More ContentExplore courses, solutions, and other research materials related to this topic.