We help IT Professionals succeed at work.
Get Started

Hyper-V showing max CPU usage for my Ubuntu VM

403 Views
Last Modified: 2012-05-12
Hi,

I have Ubuntu 10.04 Server running under Hyper-V on a Windows 2008 R2 server. SSH enabled. Using one Legacy Network Adapter, static IP.

Everything works, but normally once a day it will get 'stuck', chewing up the entire CPU committment for that VM (even when there is no visible activity in the VM itself - using HTOP to monitor it) until the VM is turned off and back on again.

I've tried installing the 'hv_' modules and using a regular Network Adapter (which does work, but same problem crops up) made sure 'ntpdate' is correct, checked the event logs on the VM Host (couldn't see anything obvious there) and tried turning off IPv4 Checksum Offload on the Host's virtual and physical NICs.

Problem still occurring.

Ideas?
Comment
Watch Question
Commented:
This problem has been solved!
Unlock 1 Answer and 3 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE