We help IT Professionals succeed at work.

Unable to view .png files in IE6 , IE7, IE8 on Windows XP SP3

Amit Khilnaney
on
Medium Priority
2,519 Views
Last Modified: 2012-05-12
Tried following methods...

 1.       System Restart

2.       Check File Type Associations. (*.PNG is associated with Picture and Fax Viewer)

3.       Tried opening .png file directly in Internet Explorer.  (Unable to display, but able to display   other images i.e. .jpg etc.)

4.       Checked security options in Internet Explorer.

5.       Reset IE.

6.       Downgrade IE7 to IE6. Same issue with IE6. with IE8 as well

7.       Reinstalled IE7

8.       Reset user profile on local system.  (I.e. deleted the user from documents and settings and then asked the user to log on
       that created a new profile)

9.       regsvr32 c:\windows\system32\pngfilt.dll (Tried registry hacks mentiond on various forms)
 

It works when

 

1.       Given admin rights to user.

2.       With Firefox.

3.       When logged in using admin on local system

4.        .png file is able to open with paint, picture viewer and other programs as well

User is a normal user on domain, like all other users but none of the users on same domain are facing issues.

Is there any user specific policy for this... which i am missing... or there is any OS Group Policy override...

I can ask user for the password and try this on another system but that's against company policy to share passwords.. I cannot ask the user to do that since a laptop is provided to user and user is WFH... User normally connects through VPN when user needs to access citrix apps or network resources otherwise user works normally without conneting to VPN.. User is very far from office cant ask the user to take a flight and come to office...

Can anybody give a detail reason of this and workable solution if anybody expericence this. I may have messed up this particular copy of OS, i think it may be messed up because i ran registry hacks, nothing else i have done with registry.
Comment
Watch Question

Tried above as well....

A step by step solution is required and reason for the step as well
Dave BaldwinFixer of Problems
CERTIFIED EXPERT
Most Valuable Expert 2014

Commented:
Can you show us the image that isn't being displayed?
CERTIFIED EXPERT
Commented:
The MS Fixit next to method A on this page will reset the security settings to their default state and that will fix the problem; but, you need to reinstall IE8 after you see it working in IE6! http://support.microsoft.com/kb/949220
Commented:
A very similar issue like yours(Chinese):
http://www.iefans.net/shouxian-ie-xianshi-png/

The author solved the problem by below steps:
1. logon with the administrator
2. run regedit, check HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/futuresplash ¿ application/x-shockwave-flash, please at least grant "read" permission to "Users" group
Commented:
And another way:
http://apps.hi.baidu.com/share/detail/230870

And some comments mention this method also solved the issue.

Author

Commented:
DaveBaldwin: I tried randomly picking some image from google image search i.e. png image.

IE with admin rights opens the image
IE with user rights doesn't

hucat: Thank you for the response, will try the method mentioned on chinese site and will update on the same

DavisMcCarn:  Thank you for the response, will try the method mentioned on Microsoft Website and will update on the same.

Author

Commented:
Though i haven't found the solution. I had to format the OS to resolve this..

Thanks all for the efforts...

Explore More ContentExplore courses, solutions, and other research materials related to this topic.