Link to home
Create AccountLog in
Avatar of carolinadon
carolinadon

asked on

Firefox: How do I fix a changed Search Engine default

Freeware (since uninstalled) left Bing droppings in Firefox and Chrome. I have changed my homepage back to Google News and the search box in the upper right corner back to Google as first choice... but when I click the NewTab icon on the toolbar it still defaults to a Bing search.

I updated to Firefox version 7.0.1 and that did fix the NewTab-icon-not-saved problem since in the newer version the "+" to add a tab is the default on the toolbar... however, clicking that "+" still brings up the Bing search page.  

( I was able to fix Chrome with a few clearly marked settings; it's not an issue.)

Running Firefox "about:config"  I found 7 lines of code in the Config file that have the word "Bing"   (see attachment)

1) The first line controls the order of the drop-down search box... Bing IS 3rd.
2) I changed the 3rd line to read "Google" instead of "Bing" but no idea what it controls; did not seem to change anything.
3) I don't know how to change lines 4 and 5 or what they control
4) I could change lines 6 and 7 to "Google" ...

anyone have any idea what these settings control or how to fix this problem.

There is a Firefox document saying to delete a program called "bingbar" to fix this problem but I do not have "bingbar" as a program nor as an Add-on.


fix3.gif
Avatar of Armand G
Armand G
Flag of New Zealand image

In the add remove programs, you need to un-install some program which is called something like "Search Toolbar" or "Search Bar". Do the same on the Mozilla Firefox add on manager.

Check this small video also to guide you through the process as described: http://www.youtube.com/watch?v=p-0NdzVovB4&noredirect=1
Avatar of carolinadon
carolinadon

ASKER

I did find a pgm called Quickstart Toolbar; I removed it.
That is partly successfully.   Bing no long shows up on
a new tab... neither does Google...  but that's ok.  

BUT  there is now a "Yahoo!" tag on the Menu (top) toolbar between
Bookmarks and Help.  And there is a Yahoo! toolbar listed in
the toolbar menu, but so far I've unchecked it and it has stayed unchecked;
I'd really like to remove it from the toolbar options if possible.

How do I get "Yahoo!" off ?

ASKER CERTIFIED SOLUTION
Avatar of Armand G
Armand G
Flag of New Zealand image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Add/Remove has no programs relating to Yahoo.

I did find a Yahoo Toolbar in plugin extensions; removed it; and restarted.
That seems to have everything back to normal.  No Yahoo! or Bing to be
found!!  

I do notice that this new Firefox version 7.0.1  is missing the "reload page" button
which I used to refresh; it's also missing from the Customize Toolbar
options.  How does one refresh a page now?

I'll leave this Bing/Yahoo issue open a day or so just to be sure, but I'm confident it's fixed.

Thank you!

How does one refresh a page now?

view
   toolbars
       customize...

Set it up anyway you like, find lost icons, make it your interface.


Cd&

Ahh... I found it... it was already on the toolbar... in the old version
I had to Customize to add it.   Ditto the NewTab icon.  

Thanks!  I'm so happy to get Firefox back to normal... shame on
MS for paying software folks to slip unwanted stuff into browers.