InfoPath 2010 Forms not opening in Browser

I designed and submitted an infopath form to a forms library.

I have also made sure that teh library is set to open forms in the web browser under the advanced settings.

I have also made sure that the form I created is set to "Web Browser Form" in the form itself

I have also made sure that under the Central Admin for my SharePoint 2010 site, I have the two InfoPath service options checked off (Allow users to browser-enable form templates, Render form templates that are browser-enabled by users )

From everything I have read, those are the three options need so I can have users open up infopath forms on computers without infopath installed but I am not having any luck with having it open in a web browser. And this is a fresh installation of Sharepoint 2010 as well. Any idea are welcome.
wydopnAsked:
Who is Participating?
 
jessc7Commented:
Go to the root site of the site collection.
Click Site Actions
Click Site Settings
Under "Site Collection Administration", click Site collection features
Scroll down to "SharePoint Server Enterprise Site Collection features"
Is this Active or not? If not, activate it.
0
 
skipper68Application Development ManagerCommented:
Do the users have local Infopath installed?  This may be overriding the settings of the browser.

Also, what is the program set to open the extension in the Folder Options on the PC itself?
0
 
wydopnAuthor Commented:
Well the doc library states to open in browser by default and if the client doesnt have it installed it wont open since it tries to default to the application regardless of my settings. and if i habe Infopath installed, it opens up fine but I am wanting my users to be able to open it with out open it up. And the extension makes no difference since it should be opening up in the browser.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jessc7Commented:
Did you enable the "SharePoint Server Enterprise Site Collection" Feature at the site collection level?
0
 
wydopnAuthor Commented:
This is a fresh build and I dont recall enabling it. Any idea where I can find it to see if it is enabled?
0
 
wydopnAuthor Commented:
I went to site settings and the option was not activated so I went ahead and activated and even went as far to restart the services incase anything needed to be restarted and client without infopath installed are still unable to view the infopath forms in the browser. All they get is the error below.

This form cannot be opened in a Web browser. To open this form, use Microsoft InfoPath.
 
Click Close to exit this message.

Hide error details
Correlation ID:879fb3e1-2e6c-4615-81b2-238103e943eb
0
 
wydopnAuthor Commented:
Ok, I think Ive got something but is a differnet problem. I got it working but when I publish the form to the forms Library and go through all the steps, it doesnt show up in the library but if I choose the "Open Form in Browser" at the end of the publsihed wizard, the form opens up and is accessible but it doesn show up in the library I published it to. But the forms dont appear anywhere for my users to click on them. I had before just put the xsn files into the forms library manually.
0
 
EvoLordCommented:
Hi Wydopn,

When you publish an infopath form to a library, the forms xsn file gets attached to the library as a template for a particular content type. What this means is :

(1) For end users to create new forms from the template they will need to click the New item of (depends on what you've called your form New form name)  from the items menu in the SP ribbon bar.

(2) For Admins to find the template file , navigate to the libraries settings page and ensure enable or manage content types is set to true under advanced. Then navigate to the forms content type ( back in the settings page) and then under template you'll find the infopath template.

You should not move the xsn file directly into the library as a clickable file.

Hope this helps,

0
 
e235500Commented:
I built up a custom formula column to build a html text  and used text2html to render it as a link in page what has the view for that form library... and the URL to be built on the formula column would be something like this http://xxx.xxx.com/sites/sitename/_layouts/FormServer.aspx?XmlLocation=/sites/sitename/formslibraryname/filname.xml&DefaultItemOpen=1

For this you should have "SharePoint Server Enterprise Site Collection features" enabled
and this formula column should be in the view.
0
 
wydopnAuthor Commented:
Final question on the matter then

Can i only have 1 infopath template per form library if I want it to be web browser enabled?

0
 
skipper68Application Development ManagerCommented:
Out of the box starting with SharePoint 2007, form libraries allowed you to publish more than one template per form library.
Document libraries also support multiple "content types" which can be used to support multiple form templates in a single document library.

These steps will enable you to have multiple forms to view past forms, but you can still only one to create new forms.  I have not personally tried to have multiple 'live' forms on one library.
Create your first InfoPath form and publish this to a new form library.
Next choose ‘fill out this form’.
     Go to your newly created form library and click on the ‘fill out this form’ link.
     Save the form in your InfoPath form library and give it a descriptive name.

Design another InfoPath form.
When clicking the save button in InfoPath choose to save this template locally (i.e. c:\temp\SecondForm.xsn).

Copy this new template into the SharePoint form library.
     Go back to the SharePoint form library and select the ‘Explorer View’
     Copy the template you’ve saved locally in the Forms folder.
          Note: make sure that the templates have different names

If you want to make the new template the default one:
     Click ‘Modify settings and columns’
     Click ‘Change general settings’
     Change the name of the form template to the name of the new form template.

You can now open the forms made with the old template and create (and open) new ones with the new template!
0
 
skipper68Application Development ManagerCommented:
Did some more digging and here's what I found, "Yes you can, you just deploy your Form as "Site Content Type" and then add the content type to your list (after enabling "Allow Management of Content Types in the Advanced Settings in your List)."

 Save As Content Type
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.