IIS/Exchange 2010 Problems

At first we were having problems when going to '/owa/' that the page was displaying blank.  I found this page: http://www.petenetlive.com/KB/Article/0000429.htm but it didn't really apply since this has been working for sometime (I did eventually try the suggested steps).  After trying to access the '/remote/' app I received an error about the web.config file not being able to display errors, so I added the code to the web.config file as suggested and now I see this error:
500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.

It appears when trying to access any of the apps: /owa, /remote, /Exchange, etc. so there is something strange going on.  I am not able to find any other diagnostic information on this problem.  Any ideas on where to go next?

The server is a Windows SBS 2011 box that has been running for some time without problems.  This error just appeared this week.
LVL 1
bdhtechnologyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bdhtechnologyAuthor Commented:
It seems as though Update Rollup 6 for Exchange Server 2010 Service Pack 1 was installed in the last few days, so that may be the root cause of all the problems.
0
bdhtechnologyAuthor Commented:
That was definitely it.  I uninstalled it and now it's back to normal.  Now if we can just figure out what caused it in the first place...
0
Cris HannaCommented:
Was this update installed via the SBS Console??
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

e_aravindCommented:
You can reinstall the Update-Rollup 6.0 on the server again
Reason: there is no known issues with the UR6.0, just the installation hiccup should be causing the above errors\warnings.

Along with the above re-install:
You could also use the command "UpdateCas.ps1"
Reference:
http://social.technet.microsoft.com/Forums/en/exchange2010/thread/dd91598d-3af9-4a98-8493-34726c763c62 
0
bdhtechnologyAuthor Commented:
Well there is a new problem now.  We started receiving this error in the event log:
The Module DLL 'C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a x86 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture mismatch error, see http://go.microsoft.com/fwlink/?LinkId=29349.

Open in new window

The Source was IIS-W3SVC-WP and the Event ID was 2282.

I followed the instructions on this page:
http://www.mosmar.com.au/chris-blog/2011/3/15/taking-care-of-bitness-or-how-to-run-a-32-bit-app-with-owa-2.html

Which did stop that error, but now there is another error and we are unable to access any pages of the site, even the default IIS index page.

Here is the new error displayed:
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.
Detailed Error Information
Module	DynamicCompressionModule
Notification	SendResponse
Handler	StaticFile
Error Code	0x8007007e
Requested URL	https://mail.cgaconsultants.com:443/
Physical Path	C:\inetpub\wwwroot
Logon Method	Anonymous
Logon User	Anonymous
Failed Request Tracing Log Directory	C:\inetpub\logs\FailedReqLogFiles

Open in new window


I did also reinstall Update Rollup 6 to no avail
0
Cris HannaCommented:
Is Exchange working at all?   If not and it was working before the update...I'd call MS support.   Those calls are supposed to be free for issues related to SP, UR, security hotfixes, etc.
0
bdhtechnologyAuthor Commented:
Exchange is working fine, it seems to be related to IIS.  I had to add: preCondition="bitness64" to DynamicCompressionModule & StaticCompressionModule.  Then I started getting this error:
Error Summary
HTTP Error 500.0 - Internal Server Error
Module "exppw" could not be found
Detailed Error Information
Module	IIS Web Core
Notification	BeginRequest
Handler	Not yet determined
Error Code	0x80070002

Open in new window


I checked the applicationHost.config and the following line appears:
<add name="exppw" image="C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\auth\exppw.dll" preCondition="bitness64" />

Open in new window


The file C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\auth\exppw.dll was there and had proper permissions.  I fixed the error by editing C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa\web.config and add the preCondition of bitness64 to it as well.  i.e.:
<add name="exppw" preCondition="bitness64" />

Open in new window

0
bdhtechnologyAuthor Commented:
The issues just keep mounting!  The issue now is that the logon comes up as a dialog box, instead of the normal HTML logon box.  Then after logging on nothing is displayed on the page.  This is the HTML sent to the browser:
<HTML>
	<HEAD>
		<TITLE>Microsoft Outlook Web App</TITLE> 
		<!--Copyright (c) 2000-2003 Microsoft Corporation. All rights reserved.-->
		<META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=utf-8">
	</HEAD>
	<FRAMESET id="fsFrm" border="1" frameborder="1" framespacing="4" cols="180,*" topmargin="0"
		leftmargin="0">
		<FRAME id="frNb" name="navbar" src="" frameborder="0" marginheight="0" marginwidth="0"
			scrolling="auto" border="1">
		<FRAME id="frVwr" frameborder="0" border="0" name="viewer" src=""
			borderColor="#264989" scrolling="auto">
		<NOFRAMES>
			<BODY>
				<P>This page uses frames, but your browser doesn't support them.</P>
			</BODY>
		</NOFRAMES>
	</FRAMESET>
</HTML>

Open in new window

0
bdhtechnologyAuthor Commented:
Well I think the root cause of it all was someone or something tried to install a 32 bit application on IIS which caused all of these errors.  I disabled the ability of IIS to run 32 bit applications via editing this configuration parameter in applicationHost.config (under <system.applicationHost><applicationPools>):

<applicationPoolDefaults enable32BitAppOnWin64="true">

Open in new window

to:
<applicationPoolDefaults>

Open in new window


Hopefully this will help someone else with similar issues.  It will disable any 32-bit application that might be installed however, so do be careful you don't break something else!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bdhtechnologyAuthor Commented:
Found the answer myself
0
Richard FrankSystems AdministratorCommented:
tnx

this is also good I noticed
<applicationPoolDefaults enable32BitAppOnWin64="false">
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.