error 1722 getting session names

Trying to send a broadcast from Windows Server 2008 to a XP station
Use msg.exe (net send does not exist anymore)
Gives the above message
But from the server to the server it works, and also from the station to itself, so it seems RPC is okay on both platform ...
LVL 1
LeTayAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ibrahim52Team LeaderCommented:
It works only on a DOMAIN environment, but if you have a WORKGROUP. It won't work.
0
ibrahim52Team LeaderCommented:
Alright, a similar discussion is available. Have a look at it. Good luck.

Referred Link :
http://www.neowin.net/forum/topic/880618-using-msgexe/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LeTayAuthor Commented:
It is in a DOMAIN dear friends
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

ibrahim52Team LeaderCommented:
But did you visit that link ?
0
LeTayAuthor Commented:
Yes but it did not help me
It is maybe a problem of firewall ...
Does msg.exe uses a specific port ?
0
Russell_VenableCommented:
Are you sure you don't have terminal services running? This is a dependancy for this to run.

I assume this is the exact error you receiving.
"Error [1722]:The RPC server is unavailable." you need to add a registry key.

HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server

Name: AllowRemoteRPC
Type: REG_DWORD
Value : 1

This enables remote RPC. RPC is port 135.

Then try "msg * /server:<domainname> "message" this will broadcast on your domain.
0
LeTayAuthor Commented:
msg.exe does not seem to work in all cases !
0
Russell_VenableCommented:
Thanks for replying. Yes, msg.exe runs using the "RpcSs" Service. Can you run "sc query RpcSss | FIND "STATE" " and display it's output?
0
LeTayAuthor Commented:
the sc query says that RpcSss does not exist as an installed service ...
0
Russell_VenableCommented:
Try dropping the last s and try it again.
0
LeTayAuthor Commented:
No answer solving my problem
0
LeTayAuthor Commented:
Sorry about that, I had many other tasks to do, and this one was not a top priority
I will come on it soon
0
LeTayAuthor Commented:
sc query rpcss state is RUNNING
still get error 1722
0
Russell_VenableCommented:
Can you post a example of the command you are using. You can omit exact domain and username using a generic format instead as long as it shows exactly what your typing for the command.
0
LeTayAuthor Commented:
I am logged on server Windows 2008
Its name is zavnt302 and the account I am logged on is vobadm
I have another PC, named h3ysh2j where I am logged on as taymans

From the server, I issue this : msg   taymans   /server:h2ysh2j "Hello World !"
I get the error 1722
From the server, I issue now : msg vobadm /server:zavnt302 "Hello World !"
I get the broadcast popup message
From the PC, I issue this : net send taymans "Hello World !"
I get the broadcast popup message
0
Russell_VenableCommented:
Well I looked further at the problem. This usually occurs when the issuer does not give "domain\user" in the command. So try entering the command "msg   "h2ysh2j \taymans"   /server:h2ysh2j "Hello World !" " and for the other "msg "zavnt302\vobadm" /server:zavnt302 "Hello World !"". See if that resolves your issue.
0
LeTayAuthor Commented:
We are in a real domain
I tried both your syntax and also with domain\user

The first (msg to other computer) failed both ways

The second (msg to local) failed (did not without) with this : zavnt302\vobadm does not exist ir is disconnected...
0
Russell_VenableCommented:
Ok, Hmm, that is how the error message is diagnosed directly from MSDN. Thought it was worth a try.  Well I do know it's a drastic change in the protocol used. May need to look into it some more and since your method works on both servers but not the  XP workstation, if no real workaround exists then there maybe a 3rd party service that you can install that supports all platforms involved. Just a thought.
0
Russell_VenableCommented:
The more I look at this. It becomes apparent that XP either is not setup correctly, incompatible to receive msg.exe RCP traffic like this or is getting blocked, since the server to server works fine. I would lean towards XP being the main problem and point all troubleshooting in this direction.
0
LeTayAuthor Commented:
Thanks for the investigation but what can I do now at client side ?
0
Russell_VenableCommented:
Is your XP client setup correctly as a terminal client role? Msg.exe runs on RPC protocol and Terminal Services. This being said it utilitizes port "3389". Which is also known as Remote Desktop Protocol. Do you have this enabled??? We already know RPC service is running from previous posts.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.