We help IT Professionals succeed at work.

No free busy information could be retrieved on exchange 2007

pdixit1977
pdixit1977 asked
on
Hi,
I just migrated about 500 users to my new Exchange 2007 servers. I still have about 100 users on the Exchange 2003 server. Whenever any of the Exchange 2007 users try to schedule a new appointment and they click on SchedulingAssistant, they get a message that

No free/busy information could be retrieved.

It doesn't matter if I add attendees that are on the old server or the new
server. Email messages flow just fine. The Exchange 2007 users use Outlook
2007.

I have 1 Hub Transport/CAS server running with Exchange 2007 with SP3 and Mailbox servers running with Exchange 2007 SP1 in CCR.
Comment
Watch Question

Maen Abu-TabanjehNetwork Administrator, Network Consultant
Top Expert 2011

Commented:
Click Start, point to Programs, point to Microsoft Exchange, and then click Microsoft Exchange Administrator.

If you are opening Exchange Administrator for the first time, click Browse to select the server that you want to administer, and then click OK.

In the navigation pane, select the server container, and then expand the server that contains the free/busy information. (This server is usually the first server in the site.)

Under the server branch, expand Public Information Store, and then click Public Folder Resources.

Note In Microsoft Exchange 2000 Server and in Microsoft Exchange Server 2003, expand Public Folder Store under the server branch, and then click Public Folder Instances.

In the details pane, double-click Schedule+ Free Busy Information.

Click the Replicas tab.

In the Replicate folders to list, follow these steps:

Add the server that you want to contain a replica of the free/busy information.

If you see more than one server in the same Exchange site, one server can be removed.

If there are no servers added for any Exchange site, add one server for that Exchange site.

Maen Abu-TabanjehNetwork Administrator, Network Consultant
Top Expert 2011

Commented:
also try run these commands in cmdlet

Get-PublicFolder -server exchsvr "\non_ipm_subtree\SCHEDULE+ FREE BUSY" -recurse | Format-List
 
Set-PublicFolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=Company/ou=First Administrative Group" -Replicas "exchsrvr\Public Folder Database"

Set-PublicFolder -Identity "\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=Company/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)" -Replicas "exchsrvr\Public Folder Database"

Author

Commented:
but as i know i need to configure availability service (audiscovery) for it.
Maen Abu-TabanjehNetwork Administrator, Network Consultant
Top Expert 2011

Commented:
you need to set autodiscover for server by using command :

Set-ClientAccessServer -identity "serverName" -AutoDiscoverServiceInternalUri https://servername.localdomain.local/autodiscover/autodiscover.xml

Set-AutodiscoverVirtualDirectory -Identity "Autodiscove
r (Default Web Site") -InternalUrl https://servername.localdomain.local/autodiscover/autodiscover.xml -ExternalUrl https://autodiscover.externaldomain.com/autodiscover/autodiscover.xml

you need to make sure that your SSL certificate is included Autodiscover.externaldomain.com
also you need to check IMAP settings :

http://technet.microsoft.com/en-us/library/aa998252(EXCHG.80).aspx

Author

Commented:
i think i already did that last time.
Is there any way thru which i can test audiscover via my outlook ?
Maen Abu-TabanjehNetwork Administrator, Network Consultant
Top Expert 2011

Commented:
via cmdlet
you need to perform these tests in powershell and see results :

Test-OutlookWebServices |fl
Test-WebServicesConnectivity |fl
Test-ImapConnectivity |fl

also you can perform test via
testexchangeconnectivity.com

its trusted site from microsoft
Commented:
Via Outlook you can test Autodiscover:
Hold Ctrl key and right mouse key above the icon of Outlook in the Taskbar and choose Test Email Autoconfiguration :)

Author

Commented:
when i tried autodiscover via way explained by coudco it hitting on mail.mydomain.com which is my 2003 box, i have created A record as autodiscover.mydomain.com and pointed it to my CAS IP but somehow its not hitting there.
Is there anything i have to do on my DNS for autodiscover ?

Author

Commented:
after making the changes suggesting by you guys the issue get granularize but it still there.

Now Exchange 2007 users are able to see free/busy data of other Exchange2007 users but not Exchange 2003 users.
Network Administrator, Network Consultant
Top Expert 2011
Commented:
the domain autdiscover detected by exchange , is not A record , its SRV record on the domain management , you should delete A record and instead add _tcp SRV record point to autodiscover.domain.com

you can test your connectivity using

www.testexchangeconnectivity.com

Author

Commented:
thnx