We help IT Professionals succeed at work.

DirectX and related issues on Win 7 Pro

core10
core10 asked
on
I've got one basic problem with multiple symptoms.

I'm running Win 7 Pro (an anytime upgrade) on a Dell Studio i5 laptop. Essentially there are several programs that simply won't install and they may share a common problem related to DirectX.

For example. I've been trying to install an AutoDesk program - Autodesk_123D_2012Beta7_English_Win_x64
and it runs into a persistent hangup during installation with both DirectX and MVB 2008. I can ignore these during the install and it completes, however running the program gives me an error thusly...

"Runtime Error! Please repair or reinstall the program.
    We’re sorry, there was an error while initializing the graphics subsystem.  This is likely due to one or more of the following:  your graphics driver is not configured for "True Color", there was a problem installing the application, the application installation was damaged, or some other problem with the graphics hardware and drivers or the configuration of the application.  More detailed information may be included below."

When I install the latest DirectX package, either in the web installer or in the downloaded package it hangs on "dx3d9_24.dll".

I've extracted this .dll out of the .cab file and manually copied it to System32 but it changes nothing.

So I can't install DirectX. I can't uninstall DirectX. I can't install Visual Basic 2008. And I can't run Microsoft's "Fix It" tool (it throws a 0xc000007b error). dxdiag shows no errors (see attached).

This looks like the same error I first got when installing AutoCAD 2009. The installation hangs on the DirectX step. AutoDesk Revit 2009 installs but perpetually shows the little blue/yellow shield in the icon and won't ever run without my authorization first. It also won't open .rvt files on double-click from explorer, although this may be unrelated.

I feel like this is the key to Dell happiness but I can't find my way out of this box! Any hints are most appreciated. However I'd prefer not to rebuild the machine again. If there's a culprit it's likely the AutoCAD 2009 installation attempt, but I can't tell for sure. I don't absolutely have to have AutoCAD on this machine. But if I don't then I'd at least like to be able to install other things that need require DirectX. DxDiag.txt
Comment
Watch Question

Top Expert 2014

Commented:
Can say I have an exact solution for you, but here's some advice.  It looks like your diaplay driver is more than 2 years old.  Try to find a newer version.  If Dell doesn't have one, then go straight to Intel.  Afterwards you can try installing Direct X again (I'm assuming you're trying to install the DX9 package), but I wouldn't think this would be necessary for the program since DX11 is included in Win7, buy maybe it needs DX9 runtimes.

A couple other basics you could try:
sfc /scannow   (to check system files)
chkdsk /r c:   (to check filesystem for errors)
Exception 0xc000007b = invalid image = there is a problem with the DVD or EXE you are installing.  Are all the installations from DVD?  If so, DVD drive may be failing.

Is Autodesk_123D_2012Beta7_English_Win_x64 the current beta version available from AutoDesk?

I agree with footech - update drivers -
Dell Studio 1569 driver downloads - http://www.dell.com/support/drivers/us/en/19

Regards. . .
jcgriff2 MVP

Commented:
Download process explorer and kill directx process and then try installing directx.

http://technet.microsoft.com/en-us/sysinternals/bb896653

You can also download handle to find out which program is accessing dx3d9_24.dll

http://technet.microsoft.com/en-us/sysinternals/bb896655

If you are able to identify the program then end the process and then try installing.


Can also try clean boot.

Put the computer in clean boot mode and then install directx


Start-type - msconfig- click on startup tab- click disable all...then click services tab- put a check on hide all microsoft services ...and then click disable all....click ok and then restart the computer in normal mode.

If everything works fine in clean boot then enable five startup items and services at a time to find the faulty software.




Ded9

Author

Commented:
Thanks for the suggestions.

footech: I've tried chkdsk and sfc already and they found no errors. I'm updating my video drivers and other dell drivers now and I'll post an update when it's all finished. It's perhaps notable that at least one of the .exe files from Dell won't install due to some security zone incompatibility. But I'm installing the AMD Radeon update and the Intel update now independent of the Dell system software.

jcgriff2: My DVD drive is definitely failing/failed. This is my second DVD drive in this system and it is just as crappy as the original. I'll likely have it replaced again before the warranty runs out (again) in April. But I'm installing from a hard drive and still experiencing the same issue. And this error shows up with other installers, not just this AutoDesk installer.

ded9: You're last up. After my driver updating I'll see if that makes a difference before working on the DirectX angle. I've tried installing DirectX so many times and in so many workarounds that I can't recall if I've ever successfully killed the service or tried the install in clean boot mode.

More to come...

Author

Commented:
I've managed to update both my ATI Radeon driver and the Intel HD driver. The Intel was very difficult as the Intel utility said it couldn't update it because the 2009 version was somehow customized. Ultimately I was able to download and unzip the latest driver and update it through Device Manager.

However, it didn't help.

I've clean booted and tried installing DirectX again with updated display drivers and no luck. I've installed Process Explorer and can't find anything that says or remotely looks like DirectX, but I don't know what to look for other than something that says something like dxd or directx or some such.

In the course of updating things I've tried to install some Dell system software that supposedly has something to do with driver updates, however during "executing update" it keeps on spinning for at least an hour before I shut it down.

If there's something related to Process Explorer that you'd like to try or see, I'm all ears. Dxdiag is attached showing the updated display driver. Note that I'm still under clean boot - the ATI stuff may not be loading.
DxDiag4.txt

Commented:
Try new user account.




Ded9

Author

Commented:
Ded9: I can't seem to add a new user given my configuration (win7 Pro on my work domain, I'm at home now and on my network via VPN). Any help?
new-user-error.jpg

Commented:
If you connected  to a domain then you will not have the rights to create an account...you need to disconnect VPN and then reboot and login locally and then create a new account.




Ded9

Author

Commented:
I've disconnected VPN (I'm only on it when I'm away from my office, otherwise I connect via cable) and rebooted - no combination of user/password gets me in besides the domain/user password combination. I've tried logging in also when not connected to any network at all and still no luck. Only my current domain/user password gets me into the machine.

That having been said, I'm an administrator on this machine and also an administrator for my domain. I can't have any more rights than that, can I?

At any rate, I can't log in or create a local user as things stand currently.

Commented:
7b also points to incorrect filesystem...run chkdsk /f on reboot and check.



Ded9

Author

Commented:
Obviously nothing has worked so far. But I did want to post an update in case it rang any bells - I just tried again to install an Autodesk beta version of 123d (123dapp.com) and it errored out early in the install saying it failed to install MS Direct3d Runtime. I don't recall if previous attempts included this particular problem or if something has changed here.

It may be worth noting that I've also recently installed the ATI drivers from Dell's website and part of that installation successfully installed Visual Studio 2005 runtimes.

I've chkdsk'd and rebooted and turned off services and all the rest and so far, no luck.

Commented:
O.S seems to be corrupted ...go for repair install..you will not loose any data or programs.

http://www.door2windows.com/forum/topic/69-how-to-do-a-repair-install-to-fix-windows-7/




Ded9

Author

Commented:
I don't have a Windows 7 DVD as this laptop came with Win 7 preinstalled. I did create a restore DVD from Dell's utility. Will that present me with a repair install option?
Commented:
Restore DVD ...i hope you used dell data safe utility to create the operating system disc.

You can peform a repair install using that disc...launch setup from the desktop and follow this article.


http://www.door2windows.com/forum/topic/69-how-to-do-a-repair-install-to-fix-windows-7/


Ded9