We help IT Professionals succeed at work.

SSL error

Hello all,
Some of users are reporting that they are getting and ssl chain error when they try to access the following link. http://bit.ly/v4s435

I have seen it in a fresh install of firefox, but it works fine for my ie and chrome installs.

Could you guys take a look and tell me if you get the error message and also what OS and browser you're using.

Thanks
Comment
Watch Question

Dave BaldwinFixer of Problems
Most Valuable Expert 2014

Commented:
Works fine in Firefox 8.  It uses an Extended Certificate so browsers that are older or not updated may have a problem with it.  Also works fine in the current versions of Chrome, Safari, IE8, and Opera.

Author

Commented:
Thanks, what would the alternative be to an extended cert?
Dave BaldwinFixer of Problems
Most Valuable Expert 2014

Commented:
Just a 'regular' one.  More info here: http://en.wikipedia.org/wiki/Extended_Validation_Certificate 

Author

Commented:
Im a little at a loss about this.

For a start, Im using Vista and Firefox 8.0.1 which I just installed, and its not working. But on Chrome and on my XP comp it works fine....

I dont understand why its working for you in firefox 8 but not for me....
Dave BaldwinFixer of Problems
Most Valuable Expert 2014

Commented:
In Firefox, go to Tools->Option->Advanced->Encryption and make sure SSL and TLS are both checked.

Author

Commented:
They are both ticked:

Use SSL 3.0

and

Use TLS 1.0
Dave BaldwinFixer of Problems
Most Valuable Expert 2014

Commented:
Click on "Request Attention" and get some others to look at your question.  Maybe someone else will know.  I'm running XP and not having any problems with that link.
Fixer of Problems
Most Valuable Expert 2014
Commented: