https authentication in ipad, iphone

hi all,

we have TMG 2010 as our proxy server. all the user have to be authenciated to access the internet.

we have configured wpad on DNS to auto discover which is working fine on microsoft platform. for mac, ipad, iphone we have to enter the URL. by entering the url in mac it also works fine. but not in ipad and iphone. it keeps asking authentication for HTTPS. we have upgraded our iphones and ipads with ios5. still keeps on prompting for authentication.

any suggestion how to solve this problem.

thanks in advance.
shahzebasifAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
Hi,

you have to configure the ipad to use Windows Integrated authentication, because your TMG firewall policy rule only allows authenticated access and the default authentication setting is Windows integrated authentication. If the ipad doesn't support integrated authentication you also have to enable basic authentication in the network object defintion INTERNAL on your TMG Server. If this also doesn't work you must consult your ipad documentation how to enable access through Proxy with authentication or create a Firewall policy rule for only the ipad clients to allow access for ALL USERS.
0
pwindellCommented:
I have never been able to get anything that starts with a lower case "i" to work in this situation.  I don't think Integrated Auth is possible since they cannot be Domain Members.  If the thing gives you a prompt for credentials then you supply them as:

User:  domain\username
Password: ******

But if you do not get a prompt then you can try enabling Basic Authentication in ISA/TMG (which I don't even remember how to do).  Basic Auth,...by nature,...always gives a prompt.  If that doesn't work,...I think you are just screwed.
0
shahzebasifAuthor Commented:
thanks for the reply.

i have tried both of the options. integrated and basic. but no use. it keeps on asking for authentication. it seems that ipad support basic authentication for http only. for https it keeps on prompting for credentials.

any workaround to solve this......
0
pwindellCommented:
Then you have already "worked around it",...you're getting the prompt.  So answer the prompt.

User:  domain\username
Password: ******


It is not going to be automatic,..you can forget that,...these "i-things" are not capable of Integrated Auth (as far as I know) and I don't believe there is a chance in the world that they ever will be.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.