• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 727
  • Last Modified:

How to discard old DNS A and PTR records on AD domain DHCP server

Hi,

on plenty of AD domain controllers I have the same issue:
local domain DNS records keep old combination of IP-ComputerName combination active in both, A-record and PTR-record. So I have under domain A-records the same NetBIOS computer name resolving to multiple IP addresses, and under reverse zone PTR having single IP resolving to multiple different NetBIOS computer names.
This is because clients were assigned new IP over years of usage, but old A and PTR records did not get deleted.
So PING and NSLOOKUP and NSLOOKUP "set type=ptr" all return mixed outputs. For some clients, which are always powered ON, results are correct, but for most of notebooks, returned values are not consistent.

But I have "Discard old PTR and A records" ENABLED, and "Update DNS entries for DHCP clients" also ENABLED under properties of DHCP server.
I also have "Remove stale records" ENABLED and set to 2-7 days.
Why do these old records not get deleted? How to set it up to work properly?
This is an issue on both, Server 2003 and Server 2008 domain, multiple installations, even on SBS 2008.

 DNSissue1.jpg DNSissue2.jpg
0
Andrej Pirman
Asked:
Andrej Pirman
  • 2
  • 2
1 Solution
 
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
0
 
Andrej PirmanAuthor Commented:
I did. So what's my sin? Which setting I set wrong?
0
 
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
Turns out the 'DNS dynamic updates registration credentials' setting in DHCP had invalid creds. The password had been changed on the account that was specified so when DHCP tried to update the records it was failing. Have created a DNS service account so this won't happen again.
go to then click credentials then re-type  user name -password - domain , then restart DHCP server .. it will work fine
0
 
Krzysztof PytkoSenior Active Directory EngineerCommented:
Make sure that your DNS zone has enabled Secure updates only and then read this blog about DNS Aging and Scavenging to understand the mechanism at
http://blogs.technet.com/b/networking/archive/2008/03/19/don-t-be-afraid-of-dns-scavenging-just-be-patient.aspx

be patient and check if it works :)

Regards,
Krzysztof
0
 
Andrej PirmanAuthor Commented:
This is the solution from your link:

Scavenging is set in three places on a Windows Server:

    - On the individual resource record to be scavenged.
    - On a zone to be scavenged.
    - At one or more servers performing scavenging.

It must be set in all three places or nothing happens.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now