Configure ip6 route on Dell PowerConnect 6248P router

hi,

i bought a Dell Powerconnect 6248P router for my company network and with hindsight its too complicated for my needs.

but - i have a problem that needs sorting.

i have configured ipv6 DHCP on my Windows Server 2008 R2 server (Stateless Mode)

the scope is fc00:1234:5678:9abc::/64

all my client machines get ip6 addresses allocated by the DHCP server.

When i try to ping an ip6 address from a computer that has been allocated its ip6 address from the DHCP server i get the following error: "PING: transmit failed. General failure."

When I manually configure the ip6 address PINK works fine.

the problem is that i need to configure the ip6 routing information on the switch as this cannot be done via the ip6 DHCP server as i understand it. (on ip4 DHCP server you configure the gateway)

i have been referring to this article: http://www.networkworld.com/community/blog/setting-dhcpv6-dynamically-issue-ipv6-address

"a)  If your routers are setup to support IPv6 with the   otherconfig=true   , effectively that your router is configured to tell your IPv6 clients their routing information, then choose to Enable DHCPv6 Stateless Mode, click Next   "

on a Dell PowerConnect 6248P how do i put this routing information in?

i have access to the web management interface, and the firmware version is 3.3.1.10.

i also have CLI access.

I have not configured any vlan's. there is only vlan1 that is configured when you run thought the Easy Configuration Wizard on the router.

any help would be most appreciated. if there is any documeantion with worked examples and step-by-step guides it would be amazing,

thanks for yoru help

jack
LVL 1
jackbensonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

harbor235Commented:


So you are using unique local addressing (ULA), which is a special class of V6 addresses not meant for routing on the public internet.

You manually configured V6 addresses, in the same ULA range? e.f. fc00:  ????

Are the V6 devices that you are trying to ping on the same network or do you have to route to get there?

More information on your setup is needed?

I also assume that the address you hand out to a DHCPV6 client has conenctivity to the end system you are trying to ping?

harbor235 ;}

0
jackbensonAuthor Commented:
harbor,

thanks for your reply.

i followed instructions from this page when i set up my ip6 DHCP server: http://programming4.us/desktop/2794.aspx

to answer your questions:

You manually configured V6 addresses, in the same ULA range? e.f. fc00:  - YES e.g. fc00:1234:5678:9abc::2

Are the V6 devices that you are trying to ping on the same network or do you have to route to get there - all on teh same network. we have 1 site only - about 15 client computers - not big


I also assume that the address you hand out to a DHCPV6 client has conenctivity to the end system you are trying to ping - the addresses handed to the clients all start with fc00:1234:5678:9abc:

in my attempt to try to fix the problem i have now made it worse. the clients no logner get IP6 addresses my by ip6 DHCP server.

i ran teh following commands on my server:
Netsh interface ipv6 add route fc00:1234:5678:9abc::/64 "Local Area Connection" publish=yes

Netsh interface ipv6 set interface "Local Area Connection" forwarding=enabled advertise=enabled nud=enabled routerdiscovery=disabled managedaddress=disabled otherstateful=disabled advertisedefaultroute=enabled

i probably ran other ones but i cant remember now

i get the following result when i run:  netsh int ipv6 show int 10

Interface Local Area Connection Parameters
----------------------------------------------
IfLuid                             : ethernet_5
IfIndex                            : 10
State                              : connected
Metric                             : 5
Link MTU                           : 1500 bytes
Reachable Time                     : 22000 ms
Base Reachable Time                : 30000 ms
Retransmission Interval            : 1000 ms
DAD Transmits                      : 1
Site Prefix Length                 : 64
Site Id                            : 1
Forwarding                         : enabled
Advertising                        : disabled
Neighbor Discovery                 : enabled
Neighbor Unreachability Detection  : enabled
Router Discovery                   : disabled
Managed Address Configuration      : disabled
Other Stateful Configuration       : disabled
Weak Host Sends                    : disabled
Weak Host Receives                 : disabled
Use Automatic Metric               : enabled
Ignore Default Routes              : disabled
Advertised Router Lifetime         : 1800 seconds
Advertise Default Route            : enabled
Current Hop Limit                  : 0
Force ARPND Wake up patterns       : disabled
Directed MAC Wake up patterns      : disabled




C:\>netsh int ipv6 show int

Idx     Met         MTU          State                Name
---  ----------  ----------  ------------  ---------------------------
  1          50  4294967295  connected     Loopback Pseudo-Interface 1
 11          50        1280  disconnected  isatap.GuideClothing.Local
 10           5        1500  connected     Local Area Connection
 12          50        1472  disconnected  Teredo Tunneling Pseudo-Interface




C:\>netsh interface ipv6 dump


# ----------------------------------
# IPv6 Configuration
# ----------------------------------
pushd interface ipv6

reset
add route prefix=::/0 interface="Local Area Connection" nexthop=fc00:1234:5678:9
abc::1 publish=Yes
add route prefix=fc00:1234:5678:9abc::/64 interface="Local Area Connection" next
hop=:: publish=Yes
set interface interface="Local Area Connection" forwarding=enabled advertise=ena
bled nud=enabled routerdiscovery=disabled managedaddress=disabled otherstateful=
disabled advertisedefaultroute=enabled
add address interface="Local Area Connection" address=fc00:1234:5678:9abc::2/64


popd
# End of IPv6 configuration



# ----------------------------------
# ISATAP Configuration
# ----------------------------------
pushd interface isatap



popd
# End of ISATAP configuration



# ----------------------------------
# 6to4 Configuration
# ----------------------------------
pushd interface 6to4

reset



popd
# End of 6to4 configuration


i hope this makes some sense.

what i want to achieve is that my ip6 DHCP server hands out addresses to by clients and they can contact eact other over IP6

thanks

jack
0
jackbensonAuthor Commented:
now when i run the following on the win 7 clients they get a ip6 address from the dhcp server:

netsh int ipv6 set int 12 routerdiscovery=disabled
netsh int ipv6 set int 12 managedaddress=enabled

all my servers are configured with static ip6 addresses e.g.

server2: fc00:1234:5678:9abc::2
server3: fc00:1234:5678:9abc::3

server2 and ping server3

one of my win 7 clients has been allocated the following ip6 address from the DHCP server: fc00:1234:5678:9abc:bad6:811:7064:720c

i cannot ping this address from server2 or server 3 - i get the error message: Request timed out.

i also cannot ping from the client to server2 or 3. i get the error message: PING: transmit failed. General failure.

does this help identiry the problem?

thanks

jack
0
harbor235Commented:

Ok, from a layer 3 perspective they are in the same network.

This is your default gateway nexthop=fc00:1234:5678:9abc::1 publish=Yes

Are servers and WIN7 client in the same layer 2 domain? i.e. are the in the same vlan? How is layer 2 configured?

harbor235 ;}
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jackbensonAuthor Commented:
hi harbor235

sorry for my delayed reply.

all win 7 clients are on the same domain. we only have 1 windows domain.. is that what you are asking.

as i tried to say.. i am a bit out of my depth with configuring the switch - when you ask: How is layer 2 configured? - do you mean on the switch?

i have not added any other vlan's to the swtich. there is only the managament vlan at the moment.

thanks

jack
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.