We help IT Professionals succeed at work.

Interactive Services Detection kept popping at Desktop's Taskbar


Ever since I printed one page from my IE8 (while readinga
website's ebook), I kept getting this Interactive Svcs Detection
that pops up at the taskbar (see attached screen)

My netbook's on Windows 7 Starter kit
InteractSvcsDetectnPop.png
Comment
Watch Question

Maen Abu-TabanjehNetwork Administrator, Network Consultant
Top Expert 2011
Commented:
right click on the icon - then Unpin this program from Taskbar

good luck
Top Expert 2013
Commented:

Author

Commented:

I've just checked the link given by RobWill & found that Interactive
Detection Svcs is already set to "Manual" & not running on my PC.

Guess I'll just have to unpin it.  
Maen Abu-TabanjehNetwork Administrator, Network Consultant
Top Expert 2011
Commented:
Top Expert 2013
Commented:
Manual doesn't mean it won't run, it just isn't automatically started when you start your PC. A service or applications will start the service as needed. Try disabling to see if it helps with the problems.
Commented:
In the "good Old Days" a service could be checked to allow "Interact with Desktop" in order for the service to post error messages to the user console.

In Windows 7 the mechanism is changed and all such service-to-user notifications run through the ISD service.

1) If you want this to STOP you have two choices
          a) Look in Computer Managment | Event viewer, find the error that is occurring, and fix it.  Look for messages from installed services, ususally the third party (non-Microsoft) ones, however ANY service can do this (I get them on MS -VPN connectoids from time to time.

          b) DISABLE the Interactive Services Detection Service.  Manual service start when needed , then stop when done
                   **** NOTE:  This will prevent ALL services from communicationg errors to the user , not just this particular one so think through this carefully.


My advice is to find out whats throwing the error and fix it, leaving ISD enabled but the settign is there to disable it for all if thats what you need.



Author

Commented:
Ok