We help IT Professionals succeed at work.

Wordpress posts and sidebar don't load

- on the page http://www.economicsjunkie.com/

- when I pull it up in Chrome the entire right sidebar and any post after the first one don't load at all

- it just keeps loading continuously but nothing happens

- in other browsers this seems to be fine
Comment
Watch Question

Jason C. LevineDon't talk to me.

Commented:
Just a guess but when I load the page on the iPad, most of the far right sidebar loads fine except for the Facebook widget and the subscribe to newsletter.  Those do eventually show up but it took a while.  

You may want to disable the facebook widget and test again.  If that fixes it, you are probably experiencing Facebook API lag.

Author

Commented:
I just removed the fb widget, but it still acts the same way. It seems like the breaking point is rather after the first ad at the bottom of the first article is displayed, because basically everything after that is missing in Chrome ...

Author

Commented:
I just put the fb widget back in since that didn't seem to change anything.
Jason C. LevineDon't talk to me.

Commented:
Actually, I just switched back to my desktop and Chrome 15.0 loads the page fine.  

Your site in Chrome 15
Do you have any ad-blocking plugins or other software of that type running?

Author

Commented:
No ad blocking software. Maybe it has something to do with the network here. Although I don't know why it would work in all other browsers in that case.
Don't talk to me.
Commented:
If there is something that is stripping out an ad, it may leave an open tag behind or something like that and the result is Chrome chokes.  The other browsers have different quirks mode adaptations so they continue to render the page.

Sorry, it's not really an answer but the best I can do given that I can't replicate it.