how to send mail from Exchange server *to* exchange server using Acronis

We have Acronis backup and recovery for our backup software running on our SBS 2008 server. This SBS server is also running Exchange Server 2007. One of the settings in Acronis lets me forward error messages to an email address. The settings request the name of the mail server, port, address, etc. This works fine when I use a gmail account as follows:

e-mail address: myaccount@gmail.com
Outgoing mail server (SMTP): smtp.gmail.com
Port: 465
User Name: myaccount@gmail.com
Password: <mygmailpassword>

When I attempt to send a test message to this account it works just fine. However, I really want to send the email to an account on my local domain. So, given that the host 'MAIL' is the local exchange server, I tried:

e-mail address: myADid@publicDomain.org
Outgoing mail server (SMTP): mail.publicDomain.org
Port: 465 | 25 (tried both)
User Name: myADid
Password: <myADpassword>

This doesn't work. I immediately fail with the message "Failed to conect to the mail server."

Since it works with the gmail server, but not with my own Exchange server, I think the problem is on my end (i.e. my firewall, Exchange, SBS ...), and not with the Acronis software.

Any ideas?
LVL 1
jmarkfoleyAsked:
Who is Participating?
 
delandaleCommented:
HI,

Please create a new connector as per the following:

(I will refer to the images above, from left to right)
Image 1 (Connector 'General' properties): Leave as default
Image 2 (Connector 'Network' properties): In the second box at the bottom, remove all entries and then add 127.0.0.1
Image 3 (Connector 'Authentication' properties): Enable the 'TLS' option and 'Basic Auth' option. Nothing else must be enabled.
Image 4 (Connector 'Permission Group' properties): Enable only 'Anonymous Users'

You must then set your backup software to send mail to the loopback address of the server (127.0.0.1) instead of the internal IP. The reason I have suggested this is because if your server gets infected with viruses and / or other malicious code that sends email, you could end up sending out loads of spam as this basically allows any mail from the server to be sent via exchange. If the backup was on a seperate server, this would not be so much of an issue however should still work. The internal IP of the server is more likely to be utilised in this manner as it is easier to identify as able to accept email than the loopback address (i.e. DNS MX lookups for example).

Regards
0
 
jmarkfoleyAuthor Commented:
More info - testing with the Exchange server, If I turn off the "Use SSL encryption" option and specify port 25 I get the message "Authentication has failed". If encryption is off and I use port 465  I get "fatal error has occured while reading from the socket."

With gmail, encryption on and port 465 works. Encryption off with port 465 doesn't work (hangs forever, or at least too long for my patience). Gmail with encryption off and port 25 fails immediately with "Authentication has failed"

So, the only configuration that works is gmail, SSL encryption on, port 465.

0
 
delandaleCommented:
Hi.

Is your backup server inside your network? If so, within ex2007, create a new receive connector that will only receive mail from your backup servers internal IP then set its authentication settings to allow TLS and Basic Auth. Set the 'Permission Groups' settings to Anonymous Users only.

If this still fails, try disabling TLS so that just Basic Auth is enabled - from your description, it sounds like you may need to do this.

Regards
0
 
jmarkfoleyAuthor Commented:
The backup server *is* the same as the Exchange server. So, I am basically sending from the backup app to Exchange on the same machine.

I'm not too familiar with creating receive connectors (if that is still what is needed). The 1st image (hub) shows my list of receive connectors. The one labeled "Default MAIL" is the Exchange Server host and also the host where the backup app runs.

The next image (properties) shows the 4 propery tabs for the "Default MAIL" connector. Given this information, do you recommend creating another receive connector, or modifying some of the settings for MAIL? Of course, mail delivery works fine for normal email delivery to users, so I wouldn't want to mess that up. (not sure why I need to mess with all this configuration for an intra-domain delivery, but oh well).

What do you think?
hub.jpg
properties.jpg
0
 
jmarkfoleyAuthor Commented:
All - I've been out for a couple of weeks. I will try the suggested solution ASAP. Please don't delete.
0
 
jmarkfoleyAuthor Commented:
I have a solution for this one I'll post shortly (need to grab an image)
0
 
jmarkfoleyAuthor Commented:
I had to do a number of things that seem extraordinarily messy.

1. First, I created a new ReceiveConnector called "Acronis".

2. Using the exchange shell I added permissions:

Get-ReceiveConnector "Acronis" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

3. In the Acronis e-mail notification configuration, I set the target email address to the distribution group I want to notify: admins@mydom.com.

4. Outgoing mail server set to 192.168.0.2, which is the domain mail server and the incoming server (albeit with a public IP).

5. port set to 25.

No user name, no password.

6. Additional email parameter, From: admins@mydom.com; use TLS encryption if possible.

That seemed to the trick. I think I've tried a number of these combinations, but probably creating the receive connector (1) and setting its permission (2) are what did the trick.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.