Website certificates don't work after firewall implementation

Hello,

Recently I implemented a Netgear Prosecure firewall. Now I'm having problems with website SSL certificates. For example, when i'm out of the company and try to connect to OWA, wich has a certificate installed that worked fine before, I get the screen that says that this website isn't trusted. When I click continue anyway, the addressbar is red. When I click 'view certificate' it says that it is issued by NetGear. When I try to reach OWA from inside the network, everything works fine including the certificate. The certificate is then issued bij Thawte, as it should be. From inside the company, a lot of HTTPS website do not work properly. I get a certificate error everytime. So it´s the same issue outbound as wel as inbound.

In the firewall I enabled port 443. What can still cause this problem??
LVL 7
SvenIAAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin SmithSr. System EngineerCommented:
THe obvious answer is you haven't configured your firewall all the way.  Is there a setting for it to act as an SSL termination point, or offload point?
0
SvenIAAuthor Commented:
Thanks for your reply. I found the solution for my problem.

On the 'application security' tab in the Services section I enabled the HTTPS web service. By default this wasn't enabled. When this option is enabled, the web certificates will be blocked by the netgear. So I turned this option off (see image).  service
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SvenIAAuthor Commented:
I resolved the problem myself.

On the 'application security' tab in the Services section I enabled the HTTPS web service. By default this wasn't enabled. When this option is enabled, the web certificates will be blocked by the netgear firewall. So I turned this option off (see image).
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.