We help IT Professionals succeed at work.

SCCM 2007 - Error 0x80070002 during OSD Task Sequence

We recently had a new model of PC and I am having trouble deploying the operating system to it using SCCM.

It crashes during the operating System deployment with the error code 0x80070002.  The PC then restarts and although Windows does boot, it is missing several drivers

I belive that all the drivers have been installed and injected into the boot image approropiratly, although it is possible I have done something incorrectly.

Can anyone advise me of some things to try please?
Comment
Watch Question

Neil RussellTechnical Development Lead

Commented:
What model of PC are you deploying to?

Author

Commented:
Its a Viglin PC with an Intel 640m motherboard and i5 processor.

Not sure why you ask though as the model is not important, just the drivers for the internal hardware is important.
Neil RussellTechnical Development Lead

Commented:
I ask because some recent PC's have very peculiar issues with new advanced format Hard Disks, specifically Dell.
As its a Viglen with a 640m, i set them up all day, it should be straight forward.
Installing the drivers into the boot image is not enough, have you created a drivers package for the actual machine deployment and added a task to install these drivers?

At exactly what point in the deployment does it crash?
Neil RussellTechnical Development Lead

Commented:
Also what OS are you deploying? Windows 7 ? 32bit or 64 bit? And is it definately a WinPE 3.x based Boot Image?

Author

Commented:
Windows 7 32bit and yes the WinPE boot image has been absoloutly fine imaging other Viglen W7 machines.

I have created a Driver Package and added it to the Distribution Point.  I have checked the TS and there is a taks to 'Apply Device Drivers' and that taks does include the driver package I created.

It fails at a weird place duing the sequence....It seems to go through all the 'Install operating System' tasks, all the setup operating system taks and actually fails at the first 'Install Software' task (which is Office 2007).

This office 2007 taks causes no problems when imaging on our other Viglen machines

Neil RussellTechnical Development Lead

Commented:
Also, some people report that dissabling the apply data Image task sequence cures lots of issues with win 7 installs. Do you use bitlocker? IF you dont and dont plan to then dissable that task sequence step and give that a try.
Neil RussellTechnical Development Lead

Commented:
from a failed machine can you post the contents of c:\windows\system32\ccm\logs\Smstslog\smsts.log
 and c:\windows\system32\ccm\logs\smsts.log
Ok, this is strange....as the problem seemed to be that it was crashing during the Office 2007 installation, I decided to move it further down the list after adobe acrobat, flash, java etc and lo and behold the installation finished this time.

I still have a GFX driver issue which I am currently waiting to see if it is working but it seems as though just moving the Office 2007 task down the list solved the problem!!
Neil RussellTechnical Development Lead

Commented:
How odd! I must admit I always put my office task last as when you get to there you know you can make the coffee :P

Author

Commented:
LOL! Good idea, well I solved the gfx issue so all is fine and dandy.

Thanks for your input, although it wasnt the direct answer, it really helped

Author

Commented:
resolution seemed to be a strange quirk, therefor I dont think this answer will help anyone else
Neil RussellTechnical Development Lead

Commented:
"Thanks for your input, although it wasnt the direct answer, it really helped"

That would normally warrent points. Saying hey that really helped! But not enough to reward you does not really encourage an expert to help.....
Nagendra Pratap SinghDesktop Applications Specialist

Commented:
Posters did decent troubleshooting and did point the OP in the right direction,