mx records between two web hosts

Hi, I have a domain registared with HOSTA


a website hosted by HOSTB

the web site works fine, but email is not happerning at all..

looking at options in consoles of both Host



doimain host

create an MX for HOST B name server

is that all i should have to do?
mhamerAsked:
Who is Participating?
 
mhamerAuthor Commented:
Hi, sorted
the host in italy (DNS), also had three other entries i couldnt se eon the console for its own nameservers

teh host in this country (web host)   had a script that wouldnt function. and create the mx records

remove the three entries form dns host and the script worked fine
0
 
mhamerAuthor Commented:
essentially why is mail  to info@profitnorthern.com not working

i see mx record pointing to ns1.mediatemple.net   which is all that should be needed.
0
 
AegilCommented:
put the mx records on the web server HOSTB server so it knows that its not responsible for mail and it should be okay. both servers should have same mx details
0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
AegilCommented:
but usually its the case when you have two hosts they both think they are responsible for everything at the domain and will try deliver locally, so you set up mx records on both so that as they will query locally for the domain they think they host they will get your updated record and send the mail out to the correct server rather than trying to send locally as they would by default.

0
 
PapertripCommented:
essentially why is mail  to info@profitnorthern.com not working
i see mx record pointing to ns1.mediatemple.net   which is all that should be needed.

You mean NS record for ns1.mediatemple.net and MX record for mail.profitnorthern.com, correct?  That is how it's currently configured.
[root@broken ~]# dig mx profitnorthern.com

; <<>> DiG 9.7.0-P2-RedHat-9.7.0-5.P2.el6_0.1 <<>> mx profitnorthern.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63843
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

;; QUESTION SECTION:
;profitnorthern.com.		IN	MX

;; ANSWER SECTION:
profitnorthern.com.	43158	IN	MX	10 mail.profitnorthern.com.

;; AUTHORITY SECTION:
profitnorthern.com.	43158	IN	NS	ns1.mediatemple.net.
profitnorthern.com.	43158	IN	NS	ns2.mediatemple.net.

;; ADDITIONAL SECTION:
mail.profitnorthern.com. 43168	IN	A	72.47.228.241

Open in new window


There is an Exim mail server listening on that server, is that configured correctly to accept mail for your domain / users?

0
 
mhamerAuthor Commented:
was an odd situation where script behind scenes wasnt working due to config of dns.

dns was corrcet it just had extra entries too that normally would not effect anything
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.