We help IT Professionals succeed at work.

Solaris 9 Not Recognsing 2nd Hard Drive

JopnHadden
JopnHadden asked
on
Hi all,

I'm trying to configure RAID 1 in Solaris 9. I have two hard drives but when I type in the format command, it only sees hd0. I have also tried multiple HDs and also swapped them round but this makes no difference - only hd0 will show so it doesn't seem to be a problem with any of the disks. I also have more than one server so I have tried it on another one but I'm getting the exact same issue.
I'm trying to install Solaris 9 on a Sunfire V245 server.

I don't know if this is something simple but I can't seem to get it to work. Any help would be greatly appreciated!
Comment
Watch Question

Commented:
Did you reconfigure?

sync; reboot -- -r

Do you have any errors in /var/adm/messages?

Commented:
Please show output of "raidctl -l" command.

Commented:
Those servers usually have hardware mirrored, "raidctl -l" will list the system's RAID configuration. But "format" command won't be able to show this.
what'a the output of cfgadm -al

Author

Commented:
Hi all, sorry for the late reply. I'm out of the office today so will try this all tomorrow.

If I type in raidctl it doesn't find any RAID arrays. I will update one I have tried it all!

Commented:
What was your update after a week :)?

Author

Commented:
Hi everyone, sorry for the delay - I have been all over the place.

So I've tried the cfgadm -al command and it lists the following about the disks:

# cfgadm -al
Ap_Id                               Type         Receptacle   Occupant     Condition
c0                                    scsi-bus     connected    configured   unknown
c0::dsk/c0t0d0                 CD-ROM       connected    configured   unknown
c1                                    scsi-bus     connected    configured   unknown
c1::dsk/c1t0d0                 disk         connected    configured   unknown

When I type in format I get this:

AVAILABLE DISK SELECTIONS:
       0. c1t0d0 <LSILOGIC-LogicalVolume-3000 cyl 65533 alt 2 hd 16 sec 136>
          /pci@1e,600000/pci@0/pci@a/pci@0/pci@8/scsi@1/sd@0,0

I'm not really sure what's going on here. raidctl -l also says that there are no RAID volumes found.

I'm going to up the points on this one as I have taken so long to reply and it seem to be a tough one.
from the output there is only one disk and CD-ROM connected to you server try to remove and connect the server again and do reconfiguration reboot "reboot -- -r" and check again,

Author

Commented:
I have now tried a reconfiguration reboot but this has not solved the issue either
Commented:
Have you looked through the /var/adm/messages log as I requested?

Also, have you checked from the PROM Monitor ("ok>") prompt that the hardware even sees the drive?

First, shut down to the ok prompt by running:  init 0

Then, from the "ok>" prompt:
ok> setenv auto-boot? false
ok> reset-all

This will reboot the system back to the ok prompt after resetting the scsi bus, so the system doesn't hang when running the probe-scsi-all command.

ok> probe-scsi-all


After you're done with this, re-enable auto-boot:

ok> setenv auto-boot? true
ok> boot