We help IT Professionals succeed at work.

ISA Server 2006 issue

Our web filtering software has its own server on our network. The software is all web based so we access the program through the web. The first part of the web address starts out with its IP address. The web address works fine when you type in its IP or name as the first part of the address.

When you turn on proxy in IE, only entering the address by name works and not IP.

Servers are running Windows 2003. Workstations are XP Pro running IE 8.
I am completely lost on why this is happening!

Thanks
Comment
Watch Question

Commented:
Temporarily turn off ad-blocking software, or you may be able to add it to your safe sites list. There may be something in your Firewall settings that may be preventing this as well.
This is the normal behavior for IE when using proxy. You can't change it.

when proxy is enabled you can browse sites only by names not IPs.

Author

Commented:
I just tested it with FireFox and everything works fine when the Proxy is on. Is there a setting in IE that needs to be changed?
No, I don't think so.
Keith AlabasterEnterprise Architect
Top Expert 2008

Commented:
Create a new rule for tcp, port 80, outbound and give it a name you will remember.
Create a new access rule from internal to the site in question using the new protocol but turn off the web proxy filter for that rule.
You may need to put this rule above the current http access rule.

Author

Commented:
I was wrong when I said it worked in FireFox. I have the same issue when I try to browse to my McAfee management interface by typing it in by it's IP address. I get the page can not be displayed. When I type it in by name it goes through fine. Both my McAfee and Websense web interface are https.

When I type in our intranet site by IP it works fine. Our intranet is not https. Could this be the problem?

Looks like our proxy server is not displaying internal sites by IP if it is using the SSL protocol?
Keith AlabasterEnterprise Architect
Top Expert 2008

Commented:
what port is the SSL site using? 443 or something different?
Open the ISA gui - select monitoring - logging - click start query. What do you see when access is attempted?
Have you implemented my suggestion above?
Commented:
I found the solution from this article.

http://www.isaserver.org/articles/2004tunnelportrange.html


I downloaded the tunnel port editor and added the SSL ports those sites were using.

Author

Commented:
I researched and found the solution.
Keith AlabasterEnterprise Architect
Top Expert 2008

Commented:
A bit miffed as I had asked the specific question - what port is the https/ssl going over but whatever, no big deal