We help IT Professionals succeed at work.

Schedule a task on Windows XP

cbeverly
cbeverly asked
on
Hello,
I am trying to schedule a task to run daily which is a script run from a browser on Windows XP.
For example, I would like the URL: http://domain.com/anyscript.cfm?RequestTimeout=300
to run on a daily basis.
I know how to schedule Firefox or Internet explorer to run but how do I make it run this URL everyday?

Thank you.
Comment
Watch Question

well running a scheduled batch file with:
iexplore.exe "http://domain.com/anyscript.cfm?RequestTimeout=300"
should work.

Only problem is that there's no way to close that window
Gary CaseRetired
Most Valuable Expert 2013
Top Expert 2009

Commented:
Simply create a shortcut to that URL => then create a scheduled task with the shortcut as the target.

Author

Commented:
I set up the shortcut then created a scheduled task with that shortcut as the target to run today for 5 minutes in the future but it never executed.
make sure the credentials work
Gary CaseRetired
Most Valuable Expert 2013
Top Expert 2009

Commented:
Did you run the shortcut to confirm it runs okay?

You may also need to set it to run with elevated permissions.
If you find a scheduled task has not run as you expected, open Scheduled Tasks and look under the Status column. The reason for the failure to complete the task should be listed. Use it to guide you toward a possible solution.

    0x0: The operation completed successfully.
    0x1: An incorrect function was called or an unknown function was called.
    0xa: The environment is incorrect.

Author

Commented:
The shortcut I created runs when I double click on it, but when I set it up as a task, it says Could not start. The log file says access denied even though permissions are all checked as allow.
If the scheduled Task has correct username, password and running service, it could be the Log On settings on the Task Scheduler service. In most cases, you use Local System account, but uncheck the Allow service interact with desktop. In the current setting, the Allow service interacts with desktop is checked. Unchecking it should fix the problem.

Author

Commented:
I checked and "The Allow service interacts with Desktop" was already unchecked.
Try checking it

Author

Commented:
I tried that and it still says it cannot start. The closest thing I can get to having it work is to schedule Internet Explorer to run and having the URL I want to run as my home page so when IE starts up, that page runs.
That works but it isn't a good solution obviously and I still welcome other solutions.

Author

Commented:
I just got it to run with firefox
C:\DOCUME~1\cbeverly\LOCALS~1\APPLIC~1\MOZILL~1\firefox.exe http://domain.com/page.cfm
I don't know what is wrong with my IE

Thanks for all your excellent help!
You're welcome. Thanks for the grade and good luck.