We help IT Professionals succeed at work.

connect two switch

c_hockland
c_hockland asked
on
when i bring the port channel up int the core switch the network comes down.
I am trying to connect sw05 to core switch sw01

config is as follows

remark ****** This is a new switch and will be connected to the Core switch TCORMCSW01 **********=


config t
hostname tcormcsw05
Username root password xxxx
enable secret xxxx
aaa new-model

clock timezone GMT 0
ip routing
ip domain-name global.abc.com
ip name-server 172.20.3.21
ip subnet-zero
no ip source-route
no ip http server
no ip http secure-server
ip classless

crypto key generate rsa

2048

exit
config t


interface Vlan1
 no ip address
 shutdown
 
 
interface Vlan101
description --- Clients ---
ip address 172.17.65.7 255.255.255.0
no shut

exit


int range fa0/1 - 46
description --- Clients  ---
switchport mode access
switchport access vlan 101
no shut


interface GigabitEthernet0/1
description --- UPlink to sw01 ---
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
duplex full
channel-group 4 mode on
no shut


interface GigabitEthernet0/2
description --- Uplink to sw01 ---
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
duplex full
channel-group 4 mode on
no shut

exit

interface Port-channel4
switchport trunk encapsulation dot1q
switchport mode trunk
 
exit

ip route 0.0.0.0 0.0.0.0 172.17.65.1 name ---->HSRP


line con 0
exec-timeout 35700 0
logging synchronous
line vty 0 4
exec-timeout 35700 0
logging synchronous
transport input ssh
transport output ssh
line vty 5 15
exec-timeout 35700 0
logging synchronous
transport input ssh
transport output ssh

end


config t
vtp domain abc
vtp mode server
vtp password abc
vtp version 2
vtp pruning
end

*************************************  On the Core switch  *************************

interface GigabitEthernet2/0/40
 description ---- PO to Sw5 ----
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 1000
 duplex full
 channel-group 4 mode on
end

interface GigabitEthernet2/0/41
 description ---- PO to Sw5 ----
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 1000
 duplex full
channel-group 4 mode on
end


interface Port-channel4
description ---- Uplink to Sw5 ----
switchport trunk encapsulation dot1q
switchport mode trunk
end


Comment
Watch Question

Just a guess, I can't tell from the config you attached but it is possible that the new switch is becoming the root bridge in spanning tree if that is in use. This would cause a recalulation of spanning tree and could cause an outage while it relearns.

If that is the case you need to change from the default settings and make the bridge priority better for the core than the new edge switch.
Marius GunnerudSenior Systems Engineer
Top Expert 2013

Commented:
Just for testing purposes, could you remove the hard-coded speed and duplex.  Gigabit switches default to speed 1000 duplex full.  I have come across some situations where the etherchannel needed the speed and duplex to be auto detected.

give that a shot and report back.

hi,

configuration looks fine as far i think,
i think u may have forgotten to turn up etherchannels interface on both,
go to ether channels interfaces and say
no shut,

if u already hv given then connect d cables and turn them down then back to up ,

i hope it work,
cheers,

Author

Commented:
ok, all inputs are great. I also suspect spanning tree. I need to do
SW3#show spanning-tree

and then

spanning-tree vlan 1 priority

do i need vlan1 or my default vlan ? in this case 101 ? and do i need to increase or decrease the priority on the new switch ?
Marius GunnerudSenior Systems Engineer
Top Expert 2013

Commented:
if you are want the switch to be the root bridge then set the priority to 0.

How many switches are interconnected in your network?

Are you using straight through cables connecting the switches together that are using the etherchannel?  If you are using straight through cables that means the switches are using auto-mdix on those ports.  This requires that speed and duplex are auto negotiated.

Author

Commented:
2 switches are interconnected
i am using etherchannel
Senior Systems Engineer
Top Expert 2013
Commented:
are there any other redundant connections outside the etherchannel?  if not then spanning tree is not the issue.