We help IT Professionals succeed at work.

Outlook 2010 automatic reply settings can not be displayed

Hi all.  Recently upgraded users to Office 2010, and everything went fairly smoothly except...

When a user is in the office, they are able to set up an automatic reply without issue.  However, when connected to the network over a VPN (through ISA 2006), they get the following message:

“Your automatic reply settings can not be displayed because the server is currently unavailable"

We are currently running Exchange 2007. I have a vague suspicion that this has something to do with autodiscover, but not sure what, since it works ok in the office but not over VPN.
Watch Question

Jon BrelieSystem Architect

With outlook open, ctrl+Click on the tray icon and select connection status.  It will show a URL for OOF settings.  Make sure that VPN users are able to access that URL.


The OOF URL is an internal address when i run the test in the office.  When i run the test over VPN, autodiscover is unable to determine my settings.  It seem to be looking for a different address over the VPN.  Why would that be?  I would think once im connected, outlook would look for the same address, just as if i were in the office...

Yeah.. Sound like the autodiscover isnt working when you are over VPN. Most probably it will be an issue with web listener and rule in ISA server. Go through the below article and check the settings on your end.





Bear in mind that users connecting over a VPN should be considered internal. You would need to check internal urls and scps.


"Bear in mind that users connecting over a VPN should be considered internal. You would need to check internal urls and scps."

Yes, i find that the problem seems to be intermittent.  Sometimes Outlook finds the internal URL's ok, and sometimes it's looking for the default external URL's.  

Additionally, this never works for non-domain joined machines, which is fine for now; i dont need it to. I need it to work for domain joined machines connected over a VPN, which, for all intents and purposes, should behave no differently than domain joined machines in the office.  
The more I think about it the more I have to agree with the advice above in that it's an autodiscover issue. Did you check the link I posted? Your Isa server might not be routing VPN traffic correctly, unfortunately I'm not an isa server expert. Sorry.