We help IT Professionals succeed at work.

Windows 7:  .VOB file play video green

detox1978
detox1978 asked
on
Hi All,

I tried to run a .VOB file for the first time on a new PC, but the screen is entirely green.  Audio comes through great.


Any thought?
Comment
Watch Question

Download latest codecs -> http://www.cccp-project.net/. One of many.

Author

Commented:
Installed it, but still get green video.
Did you try different players?
Download VLC player:  http://www.videolan.org

Good luck!
mug

Commented:
What player are you using?  These files are usually encrypted and can only be read in DVD players or DVD compatible media players.

I'd try VLC or Windows Media Player 12 or above. You could also download K-Lite Codec Pack that includes additional .VOB filters for WMP and other media players. VLC has built in Codecs and will probably do the trick.

Author

Commented:
I'm using XBMC.

Interestingly it doesnt work using Media player classic, but does using VLC.
Commented:
XBMC should play .VOB. Have you tried disabling hardware acceleration? Settings->Video->Playback

Author

Commented:
Disabling hardware acceleration does get them to work.

Any idea why, as i would like to keep HA.

Commented:
Have you tried any other .VOB's by chance??

Try to enable debugging might help us get to the bottom of this.
In Settings > System > Debugging > Enable debug logging. You may have to close the application and then relaunch it after. Try to play the file for 30 seconds and then take a look at the log file. You can just goto the Windows Start Menu > In the Search programs and files (or select run if using xp) and copy and paste this: %APPDATA%\XBMC\xbmc.log  
That should open up the log for you. Attach the log here.

Author

Commented:
Yes, all .VOB files are displayed green.

It looks like its an issue with hardware accelerating not supporting .VOB